summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-13 13:10:02 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-13 13:10:02 +0000
commitc241ffde3f4602b5f781b8852249beb38e52947d (patch)
tree4ca60cc6d8f216d29e0ee5b20ccb43a154af021a /sci-electronics/xcircuit
parentAdded missing dependency on pyparsing. (diff)
downloadhistorical-c241ffde3f4602b5f781b8852249beb38e52947d.tar.gz
historical-c241ffde3f4602b5f781b8852249beb38e52947d.tar.bz2
historical-c241ffde3f4602b5f781b8852249beb38e52947d.zip
Version bump (thanks euscan)
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog7
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.7.40.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index 325792cf3032..aa0ef79af2c8 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xcircuit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.50 2012/05/12 06:19:44 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.51 2012/06/13 13:10:02 xmw Exp $
+
+*xcircuit-3.7.40 (13 Jun 2012)
+
+ 13 Jun 2012; Michael Weber <xmw@gentoo.org> +xcircuit-3.7.40.ebuild:
+ Version bump (thanks euscan)
*xcircuit-3.7.39 (12 May 2012)
diff --git a/sci-electronics/xcircuit/xcircuit-3.7.40.ebuild b/sci-electronics/xcircuit/xcircuit-3.7.40.ebuild
new file mode 100644
index 000000000000..3c0e4fa29526
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.7.40.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.7.40.ebuild,v 1.1 2012/06/13 13:10:02 xmw Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE
+ sys-libs/zlib
+ app-text/ghostscript-gpl
+ dev-lang/tcl
+ dev-lang/tk"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+src_prepare() {
+ eautoreconf # avoid QA-warning wrt automaintainer mode
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ econf \
+ --disable-dependency-tracking \
+ --with-tcl \
+ --with-ngspice
+}
+
+src_compile() {
+ emake appdefaultsdir="/usr/share/X11/app-defaults" || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1" install || die
+ dodoc CHANGES README* TODO
+}