summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-28 19:30:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-28 19:30:52 +0000
commit72814519bb85bd44e47cac4b283cbd96bc0531f5 (patch)
treee4334ea17278006b12eb5ff36e11b556f6f73c91 /sci-chemistry
parentUse SLOT dependencies for x11-libs/gtk+. (diff)
downloadhistorical-72814519bb85bd44e47cac4b283cbd96bc0531f5.tar.gz
historical-72814519bb85bd44e47cac4b283cbd96bc0531f5.tar.bz2
historical-72814519bb85bd44e47cac4b283cbd96bc0531f5.zip
Sane check for swig version, https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=428740
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-perl/ChangeLog8
-rw-r--r--sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch25
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild8
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog8
-rw-r--r--sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch25
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild7
-rw-r--r--sci-chemistry/openbabel/ChangeLog8
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.3.0-swig.patch0
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.0.ebuild6
9 files changed, 84 insertions, 11 deletions
diff --git a/sci-chemistry/openbabel-perl/ChangeLog b/sci-chemistry/openbabel-perl/ChangeLog
index 08d09c143f48..0cb84d0039f7 100644
--- a/sci-chemistry/openbabel-perl/ChangeLog
+++ b/sci-chemistry/openbabel-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.1 2011/03/26 15:52:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.2 2011/03/28 19:28:37 jlec Exp $
+
+ 28 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-perl-2.3.0.ebuild,
+ +files/openbabel-perl-2.3.0-swig.patch:
+ Sane check for swig version,
+ https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=
+ 428740
*openbabel-perl-2.3.0 (26 Mar 2011)
diff --git a/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch b/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch
new file mode 100644
index 000000000000..6beacf74880c
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch
@@ -0,0 +1,25 @@
+ scripts/CMakeLists.txt | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
+index bf2527b..16feeb4 100644
+--- a/scripts/CMakeLists.txt
++++ b/scripts/CMakeLists.txt
+@@ -8,16 +8,12 @@ if (RUN_SWIG)
+ # SWIG_EXECUTABLE - the path to the swig executable
+ # SWIG_VERSION - the version number of the swig executable
+
+- find_package(SWIG)
++ find_package(SWIG 2.0.0)
+ if (NOT SWIG_FOUND)
+ message(STATUS "SWIG NOT found")
+ return()
+ endif (NOT SWIG_FOUND)
+ message(STATUS "SWIG version is ${SWIG_VERSION}")
+- if (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+- message(STATUS "SWIG version 2.0.0 exactly is required")
+- return()
+- endif (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+ endif (RUN_SWIG)
+
+ ###################
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
index 41f94e0ea36c..6409379f43bf 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild,v 1.1 2011/03/26 15:52:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild,v 1.2 2011/03/28 19:28:37 jlec Exp $
EAPI="3"
@@ -19,13 +19,15 @@ RDEPEND="
dev-lang/perl
~sci-chemistry/openbabel-${PV}"
DEPEND="${RDEPEND}
- =dev-lang/swig-2.0.1
+ dev-lang/swig
dev-util/cmake"
S="${WORKDIR}/openbabel-${PV}"
src_prepare() {
- epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch \
+ "${FILESDIR}/${P}-makefile.patch" \
+ "${FILESDIR}"/${P}-swig.patch
}
src_configure() {
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index e881865288d5..72f189fb370d 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.1 2011/03/26 15:34:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.2 2011/03/28 19:25:28 jlec Exp $
+
+ 28 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.0.ebuild,
+ +files/openbabel-python-2.3.0-swig.patch:
+ Sane check for swig version,
+ https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=
+ 428740
*openbabel-python-2.3.0 (26 Mar 2011)
diff --git a/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch
new file mode 100644
index 000000000000..6beacf74880c
--- /dev/null
+++ b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch
@@ -0,0 +1,25 @@
+ scripts/CMakeLists.txt | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
+index bf2527b..16feeb4 100644
+--- a/scripts/CMakeLists.txt
++++ b/scripts/CMakeLists.txt
+@@ -8,16 +8,12 @@ if (RUN_SWIG)
+ # SWIG_EXECUTABLE - the path to the swig executable
+ # SWIG_VERSION - the version number of the swig executable
+
+- find_package(SWIG)
++ find_package(SWIG 2.0.0)
+ if (NOT SWIG_FOUND)
+ message(STATUS "SWIG NOT found")
+ return()
+ endif (NOT SWIG_FOUND)
+ message(STATUS "SWIG version is ${SWIG_VERSION}")
+- if (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+- message(STATUS "SWIG version 2.0.0 exactly is required")
+- return()
+- endif (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+ endif (RUN_SWIG)
+
+ ###################
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
index 0a7aa1ff24e8..897f7b668175 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.1 2011/03/26 15:34:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.2 2011/03/28 19:25:28 jlec Exp $
EAPI="3"
@@ -26,7 +26,7 @@ RDEPEND="
~sci-chemistry/openbabel-${PV}
sys-libs/zlib"
DEPEND="${RDEPEND}
- =dev-lang/swig-2.0.1
+ dev-lang/swig
dev-util/cmake"
S="${WORKDIR}"/openbabel-${PV}
@@ -36,7 +36,8 @@ DISTUTILS_SETUP_FILES="${S}/scripts/python/setup.py"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-wrap_OBInternalCoord.patch \
- "${FILESDIR}"/${P}-py3_iterator.patch
+ "${FILESDIR}"/${P}-py3_iterator.patch \
+ "${FILESDIR}"/${P}-swig.patch
}
src_configure() {
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
index f3560685a53c..b0f83e4e2ff8 100644
--- a/sci-chemistry/openbabel/ChangeLog
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.49 2011/03/26 16:23:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.50 2011/03/28 19:30:52 jlec Exp $
+
+ 28 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-2.3.0.ebuild,
+ +files/openbabel-2.3.0-swig.patch:
+ Sane check for swig version,
+ https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=
+ 428740
26 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-2.2.3.ebuild:
Block sci-chemistry/openbabel-{python,perl}
diff --git a/sci-chemistry/openbabel/files/openbabel-2.3.0-swig.patch b/sci-chemistry/openbabel/files/openbabel-2.3.0-swig.patch
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-2.3.0-swig.patch
diff --git a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
index 441c6e5436ca..78f61b272524 100644
--- a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.3.0.ebuild,v 1.2 2011/03/26 15:54:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.3.0.ebuild,v 1.3 2011/03/28 19:30:52 jlec Exp $
EAPI="3"
@@ -32,7 +32,9 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
src_prepare() {
- epatch "${FILESDIR}"/${P}-test_lib_path.patch
+ epatch \
+ "${FILESDIR}"/${P}-test_lib_path.patch \
+ "${FILESDIR}"/${P}-swig.patch
}
src_configure() {