summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-06-06 23:32:33 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-06-06 23:32:33 +0000
commite9152f08e34c99b8efe2133cb295d37d798c3852 (patch)
tree66c459ed08efaa5ee3f107d792a822739ae2f5f9 /sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild
parentAdd Guile Scheme code that wraps the GNOME developer platform. The cairo fix ... (diff)
downloadhistorical-e9152f08e34c99b8efe2133cb295d37d798c3852.tar.gz
historical-e9152f08e34c99b8efe2133cb295d37d798c3852.tar.bz2
historical-e9152f08e34c99b8efe2133cb295d37d798c3852.zip
New package to visualize multidimensional nuclear magnetic resonance (NMR) spectra.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild')
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild
new file mode 100644
index 000000000000..e55a929bf0e8
--- /dev/null
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild,v 1.1 2007/06/06 23:32:33 dberkholz Exp $
+
+inherit eutils autotools
+
+SRC_PN="${PN/-owl}"
+SRC_P="${SRC_PN}-${PV}"
+DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${SRC_P}.tar.gz
+ examples? ( mirror://sourceforge/${PN}/${SRC_PN}-demos.tar )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+RDEPEND="=x11-libs/gtk+-2*
+ dev-scheme/guile-gnome-platform"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+S="${WORKDIR}/${SRC_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-make-script-dir.patch
+ rm -rf guile-gnome
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use examples; then
+ pushd "${WORKDIR}"/burrow-demos
+ docinto demonstration
+ dodoc * || die "dodoc demo failed"
+ cd data
+ docinto demonstration/data
+ dodoc * || die "dodoc data failed"
+ popd
+ fi
+}