summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-19 14:53:11 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-19 14:53:11 +0000
commit5437886ecfdaba2876e975d57c8527f3b8421085 (patch)
tree2ab3830d60fc499c2b409ec9412d7887eac66b34 /sci-chemistry/babel/babel-1.6-r1.ebuild
parentamd64/x86 stable, bug #242596 (diff)
downloadhistorical-5437886ecfdaba2876e975d57c8527f3b8421085.tar.gz
historical-5437886ecfdaba2876e975d57c8527f3b8421085.tar.bz2
historical-5437886ecfdaba2876e975d57c8527f3b8421085.zip
Added new and significantly cleaned up revision which also fixes pre-stripping and LDFLAGS issues (see bug #241184).
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-SENTINEL-3 i686
Diffstat (limited to 'sci-chemistry/babel/babel-1.6-r1.ebuild')
-rw-r--r--sci-chemistry/babel/babel-1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/babel/babel-1.6-r1.ebuild b/sci-chemistry/babel/babel-1.6-r1.ebuild
new file mode 100644
index 000000000000..4d7c9e1420e7
--- /dev/null
+++ b/sci-chemistry/babel/babel-1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6-r1.ebuild,v 1.1 2008/10/19 14:53:11 markusle Exp $
+
+inherit eutils
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+HOMEPAGE="http://smog.com/chem/babel/"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="!sci-chemistry/openbabel"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc32.diff
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}"/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins *.lis || die "Failed to install *.lis files"
+
+ doenvd "${FILESDIR}"/10babel || die "doenvd failed"
+ dodoc README.1ST || die "dodoc failed"
+}