summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-17 10:53:34 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-17 10:53:34 +0000
commit3ff1efcb92d907d02cc73ab9cb8aff9d0ddf1991 (patch)
treedffad588a14e9c0c3aa4dc31cc015568c18c7e4e /sci-chemistry/acpype/acpype-389.ebuild
parentremove old (diff)
downloadhistorical-3ff1efcb92d907d02cc73ab9cb8aff9d0ddf1991.tar.gz
historical-3ff1efcb92d907d02cc73ab9cb8aff9d0ddf1991.tar.bz2
historical-3ff1efcb92d907d02cc73ab9cb8aff9d0ddf1991.zip
sci-chemistry/acpype: Version Bump
Package-Manager: portage-2.2.0_alpha175/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sci-chemistry/acpype/acpype-389.ebuild')
-rw-r--r--sci-chemistry/acpype/acpype-389.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/acpype/acpype-389.ebuild b/sci-chemistry/acpype/acpype-389.ebuild
new file mode 100644
index 000000000000..38b3ef1af015
--- /dev/null
+++ b/sci-chemistry/acpype/acpype-389.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/acpype/acpype-389.ebuild,v 1.1 2013/05/17 10:53:33 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1
+
+DESCRIPTION="AnteChamber PYthon Parser interfacE"
+HOMEPAGE="http://code.google.com/p/acpype/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="sci-chemistry/ambertools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed \
+ -e '1s:^:#!/usr/bin/python\n\n:g' \
+ -i CcpnToAcpype.py || die
+}
+
+src_install() {
+ python_parallel_foreach_impl python_newscript ${PN}.py ${PN}
+ python_parallel_foreach_impl python_newscript CcpnToAcpype.py CcpnToAcpype
+ dodoc NOTE.txt README.txt
+ insinto /usr/share/${PN}
+ doins -r ffamber_additions test
+}