summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-18 17:58:11 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-18 17:58:11 +0000
commit0211cedebf6a55738c01ea13e1de3028ae416491 (patch)
treeaa8aa7ad2e23415dcae0bc134bdf4563fd0eb2a5 /sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
parentVersion bump, #124199. (diff)
downloadhistorical-0211cedebf6a55738c01ea13e1de3028ae416491.tar.gz
historical-0211cedebf6a55738c01ea13e1de3028ae416491.tar.bz2
historical-0211cedebf6a55738c01ea13e1de3028ae416491.zip
Add patch to fix compilation with gcc-4.1; bug #132336
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'sci-astronomy/setiathome/setiathome-4.18-r1.ebuild')
-rw-r--r--sci-astronomy/setiathome/setiathome-4.18-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild b/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
index 2f432e2b9597..0be36cf0f415 100644
--- a/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
+++ b/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild,v 1.4 2006/04/23 03:16:11 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18-r1.ebuild,v 1.5 2006/05/18 17:58:11 halcy0n Exp $
+
+inherit eutils
MY_PN="seti_boinc-client-cvs"
MY_PV="2005-08-20"
@@ -22,6 +24,13 @@ DEPEND="~sci-misc/boinc-4.72.20050813
S=${WORKDIR}/seti_boinc
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
# The setiathome GUI doesn't work - so disable it for now...
econf BOINCDIR=${WORKDIR}/boinc_public \