summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-09-13 17:38:31 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-09-13 17:38:31 +0000
commit89297d99aa1a1b5b834ed958ef404646e6a6f1cb (patch)
tree0c68e87222f1f74492d27d829e0ce574c2b02f79 /net-www
parentStable on hppa. (diff)
downloadhistorical-89297d99aa1a1b5b834ed958ef404646e6a6f1cb.tar.gz
historical-89297d99aa1a1b5b834ed958ef404646e6a6f1cb.tar.bz2
historical-89297d99aa1a1b5b834ed958ef404646e6a6f1cb.zip
Fixed bug
Diffstat (limited to 'net-www')
-rw-r--r--net-www/kazehakase/ChangeLog8
-rw-r--r--net-www/kazehakase/files/digest-kazehakase-0.1.9-r11
-rw-r--r--net-www/kazehakase/files/kazehakase-0.1.9_fix.patch20
-rw-r--r--net-www/kazehakase/kazehakase-0.1.9-r1.ebuild59
4 files changed, 87 insertions, 1 deletions
diff --git a/net-www/kazehakase/ChangeLog b/net-www/kazehakase/ChangeLog
index 7b1e8f2e73f8..d53daeb420e1 100644
--- a/net-www/kazehakase/ChangeLog
+++ b/net-www/kazehakase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/kazehakase
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/ChangeLog,v 1.18 2004/09/03 23:24:08 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/ChangeLog,v 1.19 2004/09/13 17:38:31 nakano Exp $
+
+*kazehakase-0.1.9-r1 (13 Sep 2004)
+
+ 13 Sep 2004; Masatomo Nakano <nakano@gentoo.org>
+ +files/kazehakase-0.1.9_fix.patch, +kazehakase-0.1.9-r1.ebuild:
+ Fixed bug that history search feature doesn't work with thumbnail.
04 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
kazehakase-0.1.6.ebuild:
diff --git a/net-www/kazehakase/files/digest-kazehakase-0.1.9-r1 b/net-www/kazehakase/files/digest-kazehakase-0.1.9-r1
new file mode 100644
index 000000000000..b6aea0f8a4e6
--- /dev/null
+++ b/net-www/kazehakase/files/digest-kazehakase-0.1.9-r1
@@ -0,0 +1 @@
+MD5 72a733327f0cdef740996b6f9efdfeba kazehakase-0.1.9.tar.gz 1045767
diff --git a/net-www/kazehakase/files/kazehakase-0.1.9_fix.patch b/net-www/kazehakase/files/kazehakase-0.1.9_fix.patch
new file mode 100644
index 000000000000..39f9eb168d7b
--- /dev/null
+++ b/net-www/kazehakase/files/kazehakase-0.1.9_fix.patch
@@ -0,0 +1,20 @@
+--- kazehakase-0.1.9/src/mozilla/kz-mozembed.cpp 2004-08-27 10:05:13.000000000 +0900
++++ kazehakase-0.1.9_fix/src/mozilla/kz-mozembed.cpp 2004-09-11 21:16:58.000000000 +0900
+@@ -633,7 +633,7 @@
+ gchar *cache = g_strconcat("file://", g_get_home_dir(),
+ HISTORY_DIR, NULL);
+ const gchar *location = kz_moz_embed_get_location(kzembed);
+- if (location && create_thumbnail &&
++ if (location &&
+ (g_str_has_prefix(location, "http:") ||
+ g_str_has_prefix(location, "https:") ||
+ g_str_has_prefix(location, "history-search:") ||
+@@ -2060,7 +2060,7 @@
+ g_return_val_if_fail (wrapper != NULL, NULL);
+
+ PRUint32 persistFlags = 0;
+-
++
+ nsCOMPtr<nsIWebBrowserPersist> bpersist =
+ do_CreateInstance(NS_WEBBROWSERPERSIST_CONTRACTID);
+ if (!bpersist) return NULL;
diff --git a/net-www/kazehakase/kazehakase-0.1.9-r1.ebuild b/net-www/kazehakase/kazehakase-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..f04206422bbe
--- /dev/null
+++ b/net-www/kazehakase/kazehakase-0.1.9-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/kazehakase/kazehakase-0.1.9-r1.ebuild,v 1.1 2004/09/13 17:38:31 nakano Exp $
+
+inherit eutils
+
+IUSE="migemo estraier"
+
+DESCRIPTION="Kazehakase is a browser with gecko engine like Epiphany or Galeon."
+HOMEPAGE="http://kazehakase.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/11115/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/automake
+ sys-devel/libtool
+ net-www/mozilla
+ x11-libs/pango
+ >=x11-libs/gtk+-2
+ dev-util/pkgconfig
+ migemo? ( app-text/migemo dev-ruby/uconv )
+ estraier? ( app-text/estraier )"
+
+RDEPEND="net-www/mozilla
+ x11-libs/pango
+ >=x11-libs/gtk+-2
+ migemo? ( app-text/migemo dev-ruby/uconv )
+ estraier? ( app-text/estraier )"
+
+pkg_setup(){
+ if grep -v gtk2 /var/db/pkg/net-www/mozilla-[[:digit:]]*/USE > /dev/null
+ then
+ echo
+ eerror
+ eerror "This needs mozilla used gtk2."
+ eerror "To build mozilla use gtk2, please type following command:"
+ eerror
+ eerror " # USE=\"gtk2\" emerge mozilla"
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/kazehakase-0.1.9_fix.patch
+}
+
+src_compile(){
+ econf `use_enable migemo` || die
+ emake || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS COPYING* ChangeLog NEWS README* TODO.ja
+}