summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-06-03 06:51:54 +0000
committerBrad Laue <brad@gentoo.org>2003-06-03 06:51:54 +0000
commit193dd28f44620df8809f0c6d1452ee269ac0e10a (patch)
treef5fbcd3cfd9e0265f19d48c90d36a8deb11959a5 /net-www
parentInitial import. Thanks to Noberasco Michele bug #17963. (diff)
downloadhistorical-193dd28f44620df8809f0c6d1452ee269ac0e10a.tar.gz
historical-193dd28f44620df8809f0c6d1452ee269ac0e10a.tar.bz2
historical-193dd28f44620df8809f0c6d1452ee269ac0e10a.zip
Fix minor issues with the ebuild
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firebird/ChangeLog3
-rw-r--r--net-www/mozilla-firebird/Manifest6
-rw-r--r--net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6-r11
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6-r1.ebuild148
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild3
5 files changed, 157 insertions, 4 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index a2012095daa6..126ab9c3020e 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,5 +1,6 @@
-# ChangeLog for net-misc/efac
+# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.2 2003/06/03 06:51:48 brad Exp $
*mozilla-firebird 0.6 (02 June 2003)
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index ec970f3d3be1..f6b8fd5e549b 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,4 +1,6 @@
-MD5 8ad1a9937f61623d3014086832409563 mozilla-firebird-0.6.ebuild 3901
-MD5 4746824a56acf37467fdb5eff4f133bf ChangeLog 300
+MD5 0a0b11d86465f6fa20dbea2b27a36239 mozilla-firebird-0.6.ebuild 4028
+MD5 7f61b1d485c9e98f6206c78c841d745a ChangeLog 419
+MD5 c5dea99630b5cbadbccc6076e3cfb262 mozilla-firebird-0.6-r1.ebuild 4031
MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6 81
+MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r1 81
diff --git a/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6-r1 b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6-r1
new file mode 100644
index 000000000000..7c8e90ff1655
--- /dev/null
+++ b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.6-r1
@@ -0,0 +1 @@
+MD5 de52dd03f8628724f14f517cd6346755 MozillaFirebird-0.6-source.tar.bz2 31992582
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6-r1.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6-r1.ebuild
new file mode 100644
index 000000000000..0c919d75a807
--- /dev/null
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r1.ebuild,v 1.1 2003/06/03 06:51:48 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins
+
+# Added to get MozillaFirebird to compile on sparc.
+replace-sparc64-flags
+
+EMVER="0.65.2"
+IPCVER="1.0.0.1"
+
+S=${WORKDIR}/mozilla
+
+DESCRIPTION="The Mozilla Firebird Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firebird/"
+SRC_URI="http://komodo.mozilla.org/pub/firebird/releases/${PV}/MozillaFirebird-${PV}-source.tar.bz2"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="java gtk2 ipv6"
+
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
+ !net-www/mozilla-firebird-bin"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-lang/perl
+ dev-util/cvs
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# needed by src_compile() and src_install()
+export MOZ_PHOENIX=1
+export MOZ_CALENDAR=0
+export MOZ_ENABLE_XFT=1
+
+src_compile() {
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --enable-xft \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --enable-optimize=-O2 \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir /${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirebird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
+
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaFirebird
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/${PN}/plugins
+
+ dobin ${FILESDIR}/MozillaFirebird
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/${PN}/plugins
+}
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild
index cbdadd7518cd..cca0caec2c2b 100644
--- a/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6.ebuild,v 1.2 2003/06/03 06:51:48 brad Exp $
inherit makeedit flag-o-matic gcc nsplugins
@@ -35,7 +36,7 @@ RDEPEND="virtual/x11
( gtk2? >=x11-libs/gtk+-2.1.1 :
=x11-libs/gtk+-1.2* )
java? ( virtual/jre )
- !net-www/MozillaFirebird-bin"
+ !net-www/mozilla-firebird-bin"
DEPEND="${RDEPEND}
virtual/glibc