summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-07-26 05:28:23 +0000
committerNed Ludd <solar@gentoo.org>2003-07-26 05:28:23 +0000
commiteaa0854d5f135e3fe038d6382c16e7d0510bb68d (patch)
treeaaaf9d2725efd020c7a444896f3eec35d98b133d /net-www/middleman
parentAdded missing support for pam and zlib, next version will have better syslogi... (diff)
downloadhistorical-eaa0854d5f135e3fe038d6382c16e7d0510bb68d.tar.gz
historical-eaa0854d5f135e3fe038d6382c16e7d0510bb68d.tar.bz2
historical-eaa0854d5f135e3fe038d6382c16e7d0510bb68d.zip
Added missing support for pam and zlib, next version will have better sysloging features
Diffstat (limited to 'net-www/middleman')
-rw-r--r--net-www/middleman/Manifest4
-rw-r--r--net-www/middleman/middleman-1.8.1.ebuild27
2 files changed, 21 insertions, 10 deletions
diff --git a/net-www/middleman/Manifest b/net-www/middleman/Manifest
index 744e89822dde..e818173f5080 100644
--- a/net-www/middleman/Manifest
+++ b/net-www/middleman/Manifest
@@ -1,6 +1,6 @@
MD5 b3089a22f33a39676bb267f8d3d59c07 metadata.xml 1012
-MD5 d556255bc0b8ed34bcb892f11506785a ChangeLog 569
-MD5 992ba7e4a125f615b699d18d2bd60980 middleman-1.8.1.ebuild 1647
+MD5 4abaf446087ca36e18f225c02876dc85 ChangeLog 569
+MD5 657ccc7549f417d41d360182fa6d80c5 middleman-1.8.1.ebuild 1647
MD5 f310f39bd53b2a586b1f6ae1755dd09c files/digest-middleman-1.8.1 67
MD5 b6b8db6ec3a0eaaad67f14c0759862a3 files/init.d/mman 951
MD5 5cca318658e1fe03d10adece2c8e4d42 files/conf.d/mman 108
diff --git a/net-www/middleman/middleman-1.8.1.ebuild b/net-www/middleman/middleman-1.8.1.ebuild
index b0f0386ecdea..99ed2062924a 100644
--- a/net-www/middleman/middleman-1.8.1.ebuild
+++ b/net-www/middleman/middleman-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/middleman-1.8.1.ebuild,v 1.1 2003/07/25 21:24:55 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/middleman/middleman-1.8.1.ebuild,v 1.2 2003/07/26 05:28:17 solar Exp $
inherit eutils
@@ -11,13 +11,15 @@ HOMEPAGE="http://sourceforge.net/projects/middle-man"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="${IUSE} pam zlib"
S=${WORKDIR}/${PN}
DEPEND="virtual/glibc
- sys-libs/zlib
- dev-libs/libpcre"
+ dev-libs/libpcre
+ pam? ( sys-libs/pam )
+ zlib? ( sys-libs/zlib )
+"
src_unpack() {
unpack ${A}
@@ -25,19 +27,28 @@ src_unpack() {
}
src_compile() {
- cd ${S}
+ local myconf=""
MAKEOPTS="-j1"
- econf --sysconfdir=/etc/mman || die "econf failed"
+
+ cd ${S}
+ for opt in ${IUSE}; do
+ use ${opt} &&
+ myconf="${myconf} --enable-${opt}" ||
+ myconf="$myconf --disable-${opt}"
+ done
+
+ econf --sysconfdir=/etc/mman ${myconf} || die "econf failed: ${myconf}"
emake || die "emake failed"
}
src_install() {
cd ${S}
- #mkdir -p ${D}/etc/mman
mkdir -p ${D}/usr/share/man/man8/
einstall || die "einstall failed"
+
dodoc CHANGELOG COPYING
dohtml README.html
+
insinto /etc/conf.d
newins ${FILESDIR}/conf.d/mman mman
exeinto /etc/init.d
@@ -52,6 +63,6 @@ src_install() {
pkg_postinst() {
#einfo "A mman user has been added to your system if one did not already exist"
einfo "-"
- einfo "Also init/conf scripts and a sample config has been provided for you."
+ einfo "Note: init/conf scripts and a sample config has been provided for you."
einfo "They can be found at or in /etc/conf.d/mman /etc/init.d/mman /etc/mman/"
}