summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-12-20 21:19:53 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-12-20 21:19:53 +0000
commitf97dda5e07d1142f5a89f6e2df550a6dc38c7eac (patch)
treedcdf620ec6a2d14b243deb11ca255f5894f6020c /net-print/hpijs/hpijs-1.7.1.ebuild
parentStable on ppc64 (diff)
downloadhistorical-f97dda5e07d1142f5a89f6e2df550a6dc38c7eac.tar.gz
historical-f97dda5e07d1142f5a89f6e2df550a6dc38c7eac.tar.bz2
historical-f97dda5e07d1142f5a89f6e2df550a6dc38c7eac.zip
version bump
Diffstat (limited to 'net-print/hpijs/hpijs-1.7.1.ebuild')
-rw-r--r--net-print/hpijs/hpijs-1.7.1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-print/hpijs/hpijs-1.7.1.ebuild b/net-print/hpijs/hpijs-1.7.1.ebuild
new file mode 100644
index 000000000000..518ef1d2922f
--- /dev/null
+++ b/net-print/hpijs/hpijs-1.7.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.7.1.ebuild,v 1.1 2004/12/20 21:19:53 lanius Exp $
+
+inherit eutils gnuconfig
+
+DB_V=1.5-20041220
+DESCRIPTION="The HP Inkjet server for Ghostscript. Provides best output for HP Inkjet Printers and some LaserJets"
+HOMEPAGE="http://hpinkjet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64"
+IUSE="cups foomaticdb ppds"
+
+DEPEND="virtual/ghostscript
+ cups? ( net-print/cups )
+ net-print/foomatic-filters
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+ epatch ${FILESDIR}/hpijs-1.4.1-rss.1.patch
+}
+
+src_compile () {
+ econf --disable-cups-install \
+ --disable-foomatic-install || die "econf failed"
+
+ sed -i -e 's|/usr/share/cups|${prefix}/share/cups|g' \
+ -e 's|/usr/lib/cups|${prefix}/lib/cups|g' Makefile \
+ || die "sed failed"
+
+ make || die "make failed"
+
+ if use foomaticdb ; then
+ cd ${WORKDIR}/foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ make || die
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ if use cups && use ppds ; then
+ dodir /usr/share/cups/model
+ dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
+ fi
+
+ if ! use ppds; then
+ rm -fR ${D}/usr/share/ppd
+ fi
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ make DESTDIR=${D} install || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ"
+ einfo "driver file for your printer from"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "This file should be installed in /etc/pdq/drivers"
+ einfo
+ einfo "The hpijs ebuild no longer creates the ppds automatically, please use"
+ einfo "foomatic to do so or remerge hpijs with the ppds use flag."
+}