summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-23 20:51:50 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-23 20:51:50 +0000
commit3173816cc2c116d12434498b513f224ac4db4cda (patch)
tree79d625ce5540dc9160859f202028c77e2ba7feba /net-p2p
parentInitial commit, pulled from java-experimental-overlay. (diff)
downloadhistorical-3173816cc2c116d12434498b513f224ac4db4cda.tar.gz
historical-3173816cc2c116d12434498b513f224ac4db4cda.tar.bz2
historical-3173816cc2c116d12434498b513f224ac4db4cda.zip
Version bump. Now supports the new Java aystem.
Package-Manager: portage-2.1.1_pre2-r4
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog13
-rw-r--r--net-p2p/azureus/azureus-2.4.0.2.ebuild114
-rw-r--r--net-p2p/azureus/files/azureus-2.4.0.2-pre60
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.4.0.23
-rw-r--r--net-p2p/azureus/metadata.xml1
5 files changed, 190 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 518764a419e4..12187cd1f58e 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.16 2006/02/12 11:36:01 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.17 2006/07/23 20:51:50 nichoj Exp $
+
+*azureus-2.4.0.2 (23 Jul 2006)
+
+ 23 Jul 2006; Joshua Nichols <jnichols@gentoo.org>
+ +files/azureus-2.4.0.2-pre, +files/fedora/azureus-cache-size.patch,
+ +files/fedora/azureus-no-restart.patch,
+ +files/fedora/azureus-remove-manifest-classpath.patch,
+ +files/fedora/azureus-remove-win32-PlatformManagerUpdateChecker.patch,
+ +files/fedora/azureus-remove-win32-osx-platforms.patch, metadata.xml,
+ +azureus-2.4.0.2.ebuild:
+ Version bump. Now supports the new Java aystem.
12 Feb 2006; Petteri Räty <betelgeuse@gentoo.org>
azureus-2.3.0.6-r1.ebuild:
diff --git a/net-p2p/azureus/azureus-2.4.0.2.ebuild b/net-p2p/azureus/azureus-2.4.0.2.ebuild
new file mode 100644
index 000000000000..2a9f4fbacf3f
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.4.0.2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.4.0.2.ebuild,v 1.1 2006/07/23 20:51:50 nichoj Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="source"
+
+RDEPEND=">=virtual/jre-1.4
+ >dev-java/swt-3.2_pre1
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bcprov-1.31
+ !net-p2p/azureus-bin"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ >=dev-java/ant-core-1.6.2
+ >=app-arch/unzip-5.0"
+
+S=${WORKDIR}/${PN}
+
+ant_src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch ${FILESDIR}/fedora/
+
+ #removing osx files and entries
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/platform/macosx
+ #removing windows files
+ rm -fr org/gudy/azureus2/platform/win32
+ #removing test files
+ rm -fr org/gudy/azureus2/ui/swt/test
+ rm -f org/gudy/azureus2/ui/console/multiuser/TestUserManager.java
+ #removing bouncycastle
+ rm -fr org/bouncycastle
+
+ mkdir -p build/libs
+ cd build/libs
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from swt-3
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ # TODO test if this is still needed, and if so, use java-config --runtime
+ # instead
+ # Figure out correct boot classpath for IBM jdk.
+ if [ ! -z "$(java-config --java-version | grep IBM)" ] ; then
+ # IBM JRE
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
+ fi
+
+ # Fails to build on amd64 or x86 without this
+ # Making this big makes x86 machines with
+ # little memory fail...
+ if use amd64 || use x86; then
+ ANT_OPTS="${ANT_OPTS} -Xmx248m"
+ fi
+
+ eant ${ant_extra_opts} jar
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar || die "dojar failed"
+
+
+ java-pkg_dolauncher ${PN} \
+ --main org.gudy.azureus2.ui.swt.Main \
+ -pre ${FILESDIR}/${P}-pre
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+ use source && java-pkg_dosrc ${S}/{com,org}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Due to the nature of the portage system, we recommend"
+ einfo "that users check portage for new versions of Azureus"
+ einfo "instead of attempting to use the auto-update feature."
+ einfo "You can disable auto-update in"
+ einfo "Tools->Options...->Interface->Start"
+ echo
+ einfo "After running azureus for the first time, configuration"
+ einfo "options will be placed in ~/.Azureus/gentoo.config"
+ einfo "It is recommended that you modify this file rather than"
+ einfo "the azureus startup script directly."
+ echo
+ einfo "As of this version, the new ui type 'console' is supported,"
+ einfo "and this may be set in ~/.Azureus/gentoo.config."
+ echo
+ ewarn "If you are upgrading, and the menu in azureus has entries like"
+ ewarn "\"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "MessageBundle.properties file,"
+ ewarn "and you may safely delete ~/.Azureus/MessagesBundle.properties"
+ echo
+ einfo "It's recommended to use Sun's Java version 1.5 or later."
+ einfo "If you're experiencing problems running azureus and you've"
+ einfo "using an older version of Java, try to upgrading to a new version. "
+ echo
+ ewarn "Please, do not run azureus as root!"
+ ewarn "Azureus has not been developed for multi-user environments!"
+}
diff --git a/net-p2p/azureus/files/azureus-2.4.0.2-pre b/net-p2p/azureus/files/azureus-2.4.0.2-pre
new file mode 100644
index 000000000000..d725445ba7c4
--- /dev/null
+++ b/net-p2p/azureus/files/azureus-2.4.0.2-pre
@@ -0,0 +1,60 @@
+#! /bin/bash
+#
+# Copyright (c) 2005, Petteri Räty <betelgeuse@gentoo.org>
+# Copyright (c) 2004, Jochen Maes <sejo@gentoo.org>
+# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright (c) 2004, Gentoo Foundation
+#
+# Licensed under the GNU General Public License, v2
+
+# The Azureus config dir has moved
+olddotazudir="${HOME}/.Azureus"
+oldgentoocfg="${olddotazudir}/gentoo.config"
+dotazudir="${HOME}/.azureus"
+gentoocfg="${dotazudir}/gentoo.config"
+
+if [[ -f "${oldgentoocfg}" && -f "${gentoocfg}" ]]; then
+ cat > /dev/stderr <<END
+You have gentoo.config files in both
+${dotazudir} and
+${olddotazudir}
+${olddotazudir} is deprecated and you can delete this directory.
+
+END
+fi
+
+if [[ -f "${gentoocfg}" ]] ; then
+ . "${gentoocfg}"
+ echo "using ${gentoocfg}"
+elif [[ -f "${oldgentoocfg}" ]]; then
+ . "${oldgentoocfg}"
+ echo "using ${oldgentoocfg}"
+else
+ if [[ ! -e "${dotazudir}" ]] ; then
+ mkdir "${dotazudir}"
+ echo "Creating ${dotazudir}"
+ fi
+
+ # Setup defaults
+ UI="swt"
+
+ echo "Creating ${gentoocfg}"
+
+ # Create the config file
+ cat > "${gentoocfg}" <<END
+# User Interface options:
+# console - console based
+# swt - swt (GUI) based
+UI="${UI}"
+
+# Options you want to pass to the java binary
+JAVA_OPTIONS=""
+END
+
+fi
+
+if [[ -n "${UI_OPTIONS}" ]]; then
+ echo '${UI_OPTIONS} is no longer supported. ${UI} should be used instead instead' > /dev/stderr
+ echo 'Unsetting ${UI_OPTIONS}'
+ unset UI_OPTIONS
+fi
diff --git a/net-p2p/azureus/files/digest-azureus-2.4.0.2 b/net-p2p/azureus/files/digest-azureus-2.4.0.2
new file mode 100644
index 000000000000..432788e32da0
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.4.0.2
@@ -0,0 +1,3 @@
+MD5 f79a2c3664fe26a21d208551bfac4b6f Azureus_2.4.0.2_source.zip 5188679
+RMD160 60b260bc34ce06ace1ae16dad330548b2db3cea7 Azureus_2.4.0.2_source.zip 5188679
+SHA256 3c25d6560110b64acf7b395950f1b9b2553a365215a0e3fb6bce3d2414147099 Azureus_2.4.0.2_source.zip 5188679
diff --git a/net-p2p/azureus/metadata.xml b/net-p2p/azureus/metadata.xml
index e234f68dc92d..377d9649bf26 100644
--- a/net-p2p/azureus/metadata.xml
+++ b/net-p2p/azureus/metadata.xml
@@ -6,4 +6,5 @@
<name>Petteri Räty</name>
<description>Maintainer</description>
</maintainer>
+ <herd>java</herd>
</pkgmetadata>