summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-24 18:36:48 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-24 18:36:48 +0000
commitdf554ef334463af9dfb327b4bc6451e37e05aa7e (patch)
tree1175a3edda42cd33111014e1d660797269a38392 /net-p2p/amule/amule-2.2.2.ebuild
parentppc stable, bug #249703 (diff)
downloadhistorical-df554ef334463af9dfb327b4bc6451e37e05aa7e.tar.gz
historical-df554ef334463af9dfb327b4bc6451e37e05aa7e.tar.bz2
historical-df554ef334463af9dfb327b4bc6451e37e05aa7e.zip
Fix gcc-4.3 build failure, bug #255783, fix gcc-4.4 build failure, bug #253143
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64
Diffstat (limited to 'net-p2p/amule/amule-2.2.2.ebuild')
-rw-r--r--net-p2p/amule/amule-2.2.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-p2p/amule/amule-2.2.2.ebuild b/net-p2p/amule/amule-2.2.2.ebuild
index e5e4036c00ec..8e3047111c2e 100644
--- a/net-p2p/amule/amule-2.2.2.ebuild
+++ b/net-p2p/amule/amule-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.2.ebuild,v 1.7 2009/01/11 19:12:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.2.ebuild,v 1.8 2009/01/24 18:36:48 armin76 Exp $
inherit eutils flag-o-matic wxwidgets
@@ -52,6 +52,14 @@ pkg_preinst() {
fi
}
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/gcc-4.3.patch
+ epatch "${FILESDIR}"/gcc-4.4.patch
+}
+
src_compile() {
local myconf