summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-27 17:18:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-27 17:18:59 +0000
commit6a27f24e223e84054661b340df37a626dfbcde2a (patch)
treed856e788e677decae3f297d05143a313526160b2 /net-p2p/amule/amule-2.2.2.ebuild
parentFix issues introduced by xulrunner 1.9.2, per bug #301831 (diff)
downloadhistorical-6a27f24e223e84054661b340df37a626dfbcde2a.tar.gz
historical-6a27f24e223e84054661b340df37a626dfbcde2a.tar.bz2
historical-6a27f24e223e84054661b340df37a626dfbcde2a.zip
Drop unused, versions that don't build with GCC 4.4.x
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'net-p2p/amule/amule-2.2.2.ebuild')
-rw-r--r--net-p2p/amule/amule-2.2.2.ebuild123
1 files changed, 0 insertions, 123 deletions
diff --git a/net-p2p/amule/amule-2.2.2.ebuild b/net-p2p/amule/amule-2.2.2.ebuild
deleted file mode 100644
index 84fcc18919c3..000000000000
--- a/net-p2p/amule/amule-2.2.2.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.2.ebuild,v 1.9 2009/03/07 15:37:22 betelgeuse Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic wxwidgets
-
-MY_P=${PN/m/M}-${PV}
-S="${WORKDIR}"/${MY_P}
-
-DESCRIPTION="aMule, the all-platform eMule p2p client"
-HOMEPAGE="http://www.amule.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 ~sparc x86"
-IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
-
-DEPEND="=x11-libs/wxGTK-2.8*
- >=dev-libs/crypto++-5.5.2
- >=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.26[jpeg] )
- geoip? ( dev-libs/geoip )
- upnp? ( >=net-libs/libupnp-1.6.6 )
- remote? ( >=media-libs/libpng-1.2.0
- unicode? ( >=media-libs/gd-2.0.26 ) )"
-
-pkg_setup() {
- if ! use gtk && ! use remote && ! use daemon; then
- eerror ""
- eerror "You have to specify at least one of gtk, remote or daemon"
- eerror "USE flag to build amule."
- eerror ""
- die "Invalid USE flag set"
- fi
-
- if use stats && ! use gtk; then
- einfo "Note: You would need both the gtk and stats USE flags"
- einfo "to compile aMule Statistics GUI."
- einfo "I will now compile console versions only."
- fi
-}
-
-pkg_preinst() {
- if use daemon || use remote; then
- enewgroup p2p
- enewuser p2p -1 -1 /home/p2p p2p
- fi
-}
-
-src_prepare() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/gcc-4.3.patch
- epatch "${FILESDIR}"/gcc-4.4.patch
-}
-
-src_configure() {
- local myconf
-
- WX_GTK_VER="2.8"
-
- if use gtk; then
- einfo "wxGTK with gtk support will be used"
- need-wxwidgets unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base
- fi
-
- if use gtk ; then
- use stats && myconf="${myconf}
- --enable-wxcas
- --enable-alc"
- use remote && myconf="${myconf}
- --enable-amule-gui"
- else
- myconf="
- --disable-monolithic
- --disable-amule-gui
- --disable-wxcas
- --disable-alc"
- fi
-
- econf \
- --with-wx-config=${WX_CONFIG} \
- --with-wxbase-config=${WX_CONFIG} \
- --enable-amulecmd \
- $(use_enable debug) \
- $(use_enable !debug optimize) \
- $(use_enable daemon amule-daemon) \
- $(use_enable geoip) \
- $(use_enable nls) \
- $(use_enable remote webserver) \
- $(use_enable stats cas) \
- $(use_enable stats alcc) \
- ${myconf} || die
-
- # we filter ssp until bug #74457 is closed to build on hardened
- filter-flags -fstack-protector -fstack-protector-all
-
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use daemon; then
- newconfd "${FILESDIR}"/amuled.confd amuled
- newinitd "${FILESDIR}"/amuled.initd amuled
- fi
-
- if use remote; then
- newconfd "${FILESDIR}"/amuleweb.confd amuleweb
- newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- fi
-}