summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-04-01 06:21:24 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-04-01 06:21:24 +0000
commit9c5e83890677b62cb48e0522508201b6c9382fcc (patch)
treeb7656bb3ffa39d6c210cc882bfc35c48628da22f /net-nds/ypbind/ypbind-1.19.1.ebuild
parentrphillips already has a mask for luabind, so I can remove mine (diff)
downloadhistorical-9c5e83890677b62cb48e0522508201b6c9382fcc.tar.gz
historical-9c5e83890677b62cb48e0522508201b6c9382fcc.tar.bz2
historical-9c5e83890677b62cb48e0522508201b6c9382fcc.zip
Install yp.conf.example instead of yp.conf. Use DESTDIR rather than einstall. Closes bug #108980.
Package-Manager: portage-2.1_pre7-r3
Diffstat (limited to 'net-nds/ypbind/ypbind-1.19.1.ebuild')
-rw-r--r--net-nds/ypbind/ypbind-1.19.1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-nds/ypbind/ypbind-1.19.1.ebuild b/net-nds/ypbind/ypbind-1.19.1.ebuild
index e2364d0eda60..853ec801c8ed 100644
--- a/net-nds/ypbind/ypbind-1.19.1.ebuild
+++ b/net-nds/ypbind/ypbind-1.19.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.19.1.ebuild,v 1.4 2006/03/31 19:28:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.19.1.ebuild,v 1.5 2006/04/01 06:21:24 eradicator Exp $
MY_P=${PN}-mt-${PV}
S="${WORKDIR}/${MY_P}"
@@ -22,17 +22,18 @@ DEPEND="${RDEPEND}
>=sys-apps/portage-2.0.51"
src_compile() {
- econf \
- $(use_enable nls) \
- $(use_enable slp) \
- || die
+ econf $(use_enable nls) $(use_enable slp)
emake || die "emake failed"
}
src_install() {
- einstall || die
+ make install DESTDIR="${D}" || die
+
dodoc AUTHORS ChangeLog README THANKS TODO
- insinto /etc ; doins etc/yp.conf
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
newconfd ${FILESDIR}/ypbind.confd-r1 ypbind
newinitd ${FILESDIR}/ypbind.initd ypbind
}