summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-21 19:09:30 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-21 19:09:30 +0000
commit14cdd54c2fbbe992929a05175671c9ca37340d62 (patch)
treebc5b9b856907c5ae031f89e629a9ad7685891b2d /net-misc
parentmake sure we only glob numbers, not . #103246 (diff)
downloadhistorical-14cdd54c2fbbe992929a05175671c9ca37340d62.tar.gz
historical-14cdd54c2fbbe992929a05175671c9ca37340d62.tar.bz2
historical-14cdd54c2fbbe992929a05175671c9ca37340d62.zip
move the sshd -t test after key generation, and update key generation to return failure if they didnt work
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/Manifest8
-rw-r--r--net-misc/openssh/files/sshd.rc613
-rw-r--r--net-misc/putty/Manifest4
3 files changed, 14 insertions, 11 deletions
diff --git a/net-misc/openssh/Manifest b/net-misc/openssh/Manifest
index 99a124a72c29..334cc5fe4af0 100644
--- a/net-misc/openssh/Manifest
+++ b/net-misc/openssh/Manifest
@@ -23,7 +23,7 @@ MD5 328a5f063659ddb400d21201feb92170 files/openssh-3.9_p1-opensc.patch.bz2 1381
MD5 85aadb893604467d9fbce08e15c1d445 files/digest-openssh-4.0_p1-r2 360
MD5 b86ae0c43a704c4ee2abd2ce5c955f8f files/sshd.pam 294
MD5 4bee5c8ce11f30487154c3742e004f7d files/openssh-4.0_p1-smartcard-ldap-happy.patch 545
-MD5 95e348031a7ed6905b9c3230bc7f916f files/sshd.rc6 1235
+MD5 5afc89edd73f522a5b3757a518dffb34 files/sshd.rc6 1293
MD5 73f3b46d27bd413eb79350a2ce412bf6 files/openssh-3.9_p1-pamfix.patch.bz2 1125
MD5 7880e18b2a91e5927810dddc7bda270f files/openssh-3.7.1_p1-selinux.diff.bz2 1353
MD5 f68837d6568b1c98ef01db0ab629a171 files/openssh-3.9_p1-sftplogging-1.2-gentoo.patch.bz2 5935
@@ -49,7 +49,7 @@ MD5 f5e33d1831f95c821a08893bcf3e3f5f files/openssh-4.0_p1-sftplogging-1.2-gentoo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDBqfGgIKl8Uu19MoRAkXKAJ417gZmvrPEeCMlUZ/oBAQToBamXACeNAZ3
-Ld5jdAu4gpb8S5cALbqjOBQ=
-=5iyR
+iD8DBQFDCNGfgIKl8Uu19MoRAo7xAJ95T6a8fdlK1Ie3dFh0DZCxMxlHCgCfVANS
+4KdLbO96GUzNGbGIHFTOkm4=
+=aXZ8
-----END PGP SIGNATURE-----
diff --git a/net-misc/openssh/files/sshd.rc6 b/net-misc/openssh/files/sshd.rc6
index ec598cee8822..01083d1d0fc6 100644
--- a/net-misc/openssh/files/sshd.rc6
+++ b/net-misc/openssh/files/sshd.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/files/sshd.rc6,v 1.15 2005/08/20 03:46:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/files/sshd.rc6,v 1.16 2005/08/21 19:09:30 vapier Exp $
depend() {
use logger dns
@@ -19,24 +19,25 @@ checkconfig() {
return 1
fi
- /usr/sbin/sshd -t || return 1
+ gen_keys || return 1
- gen_keys
+ /usr/sbin/sshd -t || return 1
}
gen_keys() {
if [ ! -e /etc/ssh/ssh_host_key ] ; then
einfo "Generating Hostkey..."
- /usr/bin/ssh-keygen -t rsa1 -b 1024 -f /etc/ssh/ssh_host_key -N ''
+ /usr/bin/ssh-keygen -t rsa1 -b 1024 -f /etc/ssh/ssh_host_key -N '' || return 1
fi
if [ ! -e /etc/ssh/ssh_host_dsa_key ] ; then
einfo "Generating DSA-Hostkey..."
- /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N ''
+ /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N '' || return 1
fi
if [ ! -e /etc/ssh/ssh_host_rsa_key ] ; then
einfo "Generating RSA-Hostkey..."
- /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N ''
+ /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N '' || return 1
fi
+ return 0
}
start() {
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index a84a04900900..e22405b5befa 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,6 +1,8 @@
+MD5 1e8975a296dc9b21230b6a4eccd0e67f putty-0.58.ebuild 1555
MD5 4a383beb375f4954b2af0c9d53acfc22 putty-0.57.ebuild 1820
-MD5 100121157f8df739c1824c18117fe7d7 ChangeLog 3548
+MD5 6af0d0104abaceca6cfc9df8873ec457 ChangeLog 3652
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 3a07269379d199e6363fbe0250c5899a files/digest-putty-0.57 63
+MD5 7c38293f57fa00b6d687477113f0625b files/digest-putty-0.58 63
MD5 4f674a5fd23877ac6d76c6d9baa33041 files/putty-ut_time.patch 824
MD5 85355228c88a7a925e751df0f058f0ea files/putty.desktop 207