summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2005-01-04 01:21:12 +0000
committerWolfram Schlich <wschlich@gentoo.org>2005-01-04 01:21:12 +0000
commit4040c2c46435de74af90deca07cbd262c4704523 (patch)
tree4a7600c34a28df790b90397c0fdf0f722334467b /net-misc/wol/wol-0.7.1.ebuild
parentupdates for embedded systems (diff)
downloadhistorical-4040c2c46435de74af90deca07cbd262c4704523.tar.gz
historical-4040c2c46435de74af90deca07cbd262c4704523.tar.bz2
historical-4040c2c46435de74af90deca07cbd262c4704523.zip
initial import
Diffstat (limited to 'net-misc/wol/wol-0.7.1.ebuild')
-rw-r--r--net-misc/wol/wol-0.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/wol/wol-0.7.1.ebuild b/net-misc/wol/wol-0.7.1.ebuild
new file mode 100644
index 000000000000..ff533fe00a76
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wol/wol-0.7.1.ebuild,v 1.1 2005/01/04 01:21:12 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}