summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-11-12 13:11:17 +0000
committerNed Ludd <solar@gentoo.org>2005-11-12 13:11:17 +0000
commite50afa39301096b06c06c7ab3f6f75a00f840db4 (patch)
tree0111cf8283c8acb46785d59044d997b581bd4691 /net-misc/vconfig/vconfig-1.9.ebuild
parentNew dep for app-misc/bins (diff)
downloadhistorical-e50afa39301096b06c06c7ab3f6f75a00f840db4.tar.gz
historical-e50afa39301096b06c06c7ab3f6f75a00f840db4.tar.bz2
historical-e50afa39301096b06c06c7ab3f6f75a00f840db4.zip
- version bump. This release fixes return error codes in vconfig.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-misc/vconfig/vconfig-1.9.ebuild')
-rw-r--r--net-misc/vconfig/vconfig-1.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/vconfig/vconfig-1.9.ebuild b/net-misc/vconfig/vconfig-1.9.ebuild
new file mode 100644
index 000000000000..cee345e4a5bc
--- /dev/null
+++ b/net-misc/vconfig/vconfig-1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/vconfig-1.9.ebuild,v 1.1 2005/11/12 13:11:17 solar Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_PN="vlan"
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="802.1Q vlan control utility"
+HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
+SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz"
+# mirror://gentoo/vconfig-1.7-gcc33-multiline.patch"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static"
+DEPEND="virtual/libc virtual/os-headers"
+RDEPEND="!static? ( virtual/libc )"
+
+src_unpack() {
+ unpack ${MY_PN}.${PV}.tar.gz
+}
+
+src_compile() {
+ use static && appened-ldflags -static
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ into /
+ dosbin vconfig || die "dosbin error"
+
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test.pl
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test2.pl
+
+ doman vconfig.8 || die "doman error"
+ dohtml howto.html vlan.html || die "dohtml error"
+ dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
+}
+
+pkg_postinst() {
+ einfo "802.1Q VLAN support is now in the linux kernel as of 2.4.14."
+ ewarn "MTU problems exist for many ethernet drivers."
+ ewarn "Reduce the MTU on the interface to 1496 to work around them."
+}