summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-07 20:31:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-07 20:31:13 +0000
commit681fef10d2f5027c08a4e12c90fcd7252e6d37b0 (patch)
tree6710da800ed2f86d87ba805e174efb57a07b17fc /net-misc/taptap
parentDelete older ebuild. (diff)
downloadhistorical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.tar.gz
historical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.tar.bz2
historical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.zip
Initial commit wrt #340861 by Alex Buell.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'net-misc/taptap')
-rw-r--r--net-misc/taptap/ChangeLog9
-rw-r--r--net-misc/taptap/Manifest4
-rw-r--r--net-misc/taptap/metadata.xml9
-rw-r--r--net-misc/taptap/taptap-1.0.ebuild32
4 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/taptap/ChangeLog b/net-misc/taptap/ChangeLog
new file mode 100644
index 000000000000..a322556c151f
--- /dev/null
+++ b/net-misc/taptap/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/taptap
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taptap/ChangeLog,v 1.1 2010/11/07 20:31:13 ssuominen Exp $
+
+*taptap-1.0 (07 Nov 2010)
+
+ 07 Nov 2010; Samuli Suominen <ssuominen@gentoo.org> +taptap-1.0.ebuild:
+ Initial commit wrt #340861 by Alex Buell.
+
diff --git a/net-misc/taptap/Manifest b/net-misc/taptap/Manifest
new file mode 100644
index 000000000000..7210fe38fd2b
--- /dev/null
+++ b/net-misc/taptap/Manifest
@@ -0,0 +1,4 @@
+DIST taptap-1.0.tar.bz2 1640 RMD160 44df0e244ba8236633b1980a02fd8314126ac470 SHA1 a5bb063d7176d659d43c9b36c2288aa515832611 SHA256 cb4273ee00ad488b648547aea39ecf345ad5badde613285347b9df5f3a84dd28
+EBUILD taptap-1.0.ebuild 749 RMD160 b47dd744fae89636838b69183b6d5db5551bba48 SHA1 da712eef2422edacb9a11c9e312976d1c5097cd7 SHA256 587726d06af7fba0e3f9ed4c6f6379232f69b8763e9a1d41a521d47d0330099d
+MISC ChangeLog 352 RMD160 e0e28a9cc5d4477c0506d4733262e32ceca419a3 SHA1 c40de71cee98bf30410f069af3fb0f59cbc54f91 SHA256 4ed2e3e9ec04f5e8666dbf3877fd502ab5f57c8795374394661f7eead5310ca9
+MISC metadata.xml 266 RMD160 b4480e6518739202d8543a84b01b53940907f016 SHA1 3a5b0bff8b6ad1614a1e8fcbecddf54b800c80a2 SHA256 7aba9af99c2de45240978680e160a1bc959795d16c7eeeae6f2822ba59da9af2
diff --git a/net-misc/taptap/metadata.xml b/net-misc/taptap/metadata.xml
new file mode 100644
index 000000000000..7cc5007c5d79
--- /dev/null
+++ b/net-misc/taptap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/taptap/taptap-1.0.ebuild b/net-misc/taptap/taptap-1.0.ebuild
new file mode 100644
index 000000000000..4d0dae141d2c
--- /dev/null
+++ b/net-misc/taptap/taptap-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taptap/taptap-1.0.ebuild,v 1.1 2010/11/07 20:31:13 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A program to link two /dev/net/tun to form virtual ethernet"
+HOMEPAGE="http://www.munted.org.uk/programming/taptap/"
+SRC_URI="http://www.munted.org.uk/programming/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:= -Wall -s:+= -Wall:' \
+ -e 's:$(CFLAGS):$(LDFLAGS) &:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}