summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-05-08 20:31:28 +0000
committerJeroen Roovers <jer@gentoo.org>2011-05-08 20:31:28 +0000
commit9db04a1e447feedbee6fc4ce0595dd2ff5c7174a (patch)
tree1cf6b15a4233cedc080e3c20d14acc5687e0ec3c /net-misc/switzerland
parentVersion bump. Respect CFLAGS. (diff)
downloadhistorical-9db04a1e447feedbee6fc4ce0595dd2ff5c7174a.tar.gz
historical-9db04a1e447feedbee6fc4ce0595dd2ff5c7174a.tar.bz2
historical-9db04a1e447feedbee6fc4ce0595dd2ff5c7174a.zip
Version bump thanks to Arfrever Frehtes Taifersar Arahesis (bug #362219).
Package-Manager: portage-2.2.0_alpha31/cvs/Linux i686
Diffstat (limited to 'net-misc/switzerland')
-rw-r--r--net-misc/switzerland/ChangeLog8
-rw-r--r--net-misc/switzerland/files/Makefile2
-rw-r--r--net-misc/switzerland/switzerland-0.1.0.ebuild50
3 files changed, 58 insertions, 2 deletions
diff --git a/net-misc/switzerland/ChangeLog b/net-misc/switzerland/ChangeLog
index ab27cf9174f4..ba531cd03241 100644
--- a/net-misc/switzerland/ChangeLog
+++ b/net-misc/switzerland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/switzerland
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/switzerland/ChangeLog,v 1.2 2011/04/05 20:20:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/switzerland/ChangeLog,v 1.3 2011/05/08 20:31:28 jer Exp $
+
+*switzerland-0.1.0 (08 May 2011)
+
+ 08 May 2011; Jeroen Roovers <jer@gentoo.org> +switzerland-0.1.0.ebuild,
+ files/Makefile:
+ Version bump thanks to Arfrever Frehtes Taifersar Arahesis (bug #362219).
05 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
switzerland-0.0.5.ebuild:
diff --git a/net-misc/switzerland/files/Makefile b/net-misc/switzerland/files/Makefile
index 12e587f689f8..39bcc0e426ff 100644
--- a/net-misc/switzerland/files/Makefile
+++ b/net-misc/switzerland/files/Makefile
@@ -15,4 +15,4 @@ all: FastCollector
${CC} -c ${CFLAGS} $<
FastCollector: ${OBJ}
- ${LD} -o $@ ${LDFLAGS} ${OBJ} ${LIBS}
+ ${LD} -o $@ ${CFLAGS} ${LDFLAGS} ${OBJ} ${LIBS}
diff --git a/net-misc/switzerland/switzerland-0.1.0.ebuild b/net-misc/switzerland/switzerland-0.1.0.ebuild
new file mode 100644
index 000000000000..c09eec2bc8ee
--- /dev/null
+++ b/net-misc/switzerland/switzerland-0.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/switzerland/switzerland-0.1.0.ebuild,v 1.1 2011/05/08 20:31:28 jer Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="Switzerland Network Testing Tool"
+HOMEPAGE="http://www.eff.org/testyourisp/switzerland/"
+SRC_URI="mirror://sourceforge/switzerland/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile switzerland/client
+
+ sed -i \
+ -e "s/= find_binary()/= dest/" \
+ setup.py
+}
+
+src_compile() {
+ cd switzerland/client
+ emake CC=$(tc-getCC) || die "emake failed"
+
+ cd "${S}"
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc BUGS.txt CREDITS
+
+ keepdir /var/log/switzerland-pcaps
+ keepdir /var/log/switzerland
+}