summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-04 19:48:22 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-04 19:48:22 +0000
commit4c49a24cf9af55c715cca8b32e498668321339ab (patch)
treeff40e550491c9daf19093e66071c01a2a114e5e4 /net-misc/rsync
parentMasked media-gfx/pixieplus; needs testing. (diff)
downloadhistorical-4c49a24cf9af55c715cca8b32e498668321339ab.tar.gz
historical-4c49a24cf9af55c715cca8b32e498668321339ab.tar.bz2
historical-4c49a24cf9af55c715cca8b32e498668321339ab.zip
new version
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/files/digest-rsync-2.5.11
-rw-r--r--net-misc/rsync/rsync-2.5.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.5.1 b/net-misc/rsync/files/digest-rsync-2.5.1
new file mode 100644
index 000000000000..1d9e44fe5649
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.5.1
@@ -0,0 +1 @@
+MD5 47a3787f7c5f3c554b894a24ed092c82 rsync-2.5.1.tar.gz 454656
diff --git a/net-misc/rsync/rsync-2.5.1.ebuild b/net-misc/rsync/rsync-2.5.1.ebuild
new file mode 100644
index 000000000000..4d8073544156
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.1.ebuild,v 1.1 2002/01/04 19:48:22 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File transfer program to keep remote files into sync"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
+HOMEPAGE="http://rsync.samba.org"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+#change confdir to /etc/rsync rather than just /etc (the --sysconfdir configure option doesn't work
+ cp rsync.h rsync.h.orig
+ sed -e 's:RSYNCD_CONF "/etc/rsyncd.conf":RSYNCD_CONF "/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h
+#yes, updating the man page is very important.
+ cp rsyncd.conf.5 rsyncd.conf.5.orig
+ sed -e 's:/etc/rsyncd:/etc/rsync/rsyncd:g' rsyncd.conf.5.orig > rsyncd.conf.5
+}
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ if [ "`use static`" ] ; then
+ emake LDFLAGS="-static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+ if [ -z "`use build`" ]
+ then
+ dodir /etc/rsync
+ dodoc COPYING NEWS OLDNEWS README TODO tech_report.tex
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ if [ ! -d /etc/rsync ]
+ then
+ mkdir /etc/rsync
+ fi
+}