summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-09 00:06:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-09 00:06:53 +0000
commit3b9b089a5e4214e001b1b2cb9b788ec39bd6029c (patch)
tree9f864a2484bb422613082d43a23244c1eed7b37d /net-misc/pump/pump-0.8.11-r1.ebuild
parentAdd sparc patchset to 2.6.4-rc2. (diff)
downloadhistorical-3b9b089a5e4214e001b1b2cb9b788ec39bd6029c.tar.gz
historical-3b9b089a5e4214e001b1b2cb9b788ec39bd6029c.tar.bz2
historical-3b9b089a5e4214e001b1b2cb9b788ec39bd6029c.zip
revision bumps to PROVIDE virtual/dhcpc, thanks to a request by William Hubbs <kc5eiv@kc5eiv.homeip.net> on the gentoo-dev mailing list: http://article.gmane.org/gmane.linux.gentoo.devel/11579
Diffstat (limited to 'net-misc/pump/pump-0.8.11-r1.ebuild')
-rw-r--r--net-misc/pump/pump-0.8.11-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/pump/pump-0.8.11-r1.ebuild b/net-misc/pump/pump-0.8.11-r1.ebuild
new file mode 100644
index 000000000000..a7479fb7f906
--- /dev/null
+++ b/net-misc/pump/pump-0.8.11-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.11-r1.ebuild,v 1.1 2004/03/09 00:06:53 seemant Exp $
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND=">=dev-libs/popt-1.5"
+
+PROVIDE="virtual/dhcpc"
+
+src_compile() {
+ make pump || die
+}
+
+src_install () {
+ exeinto /sbin
+ doexe pump
+
+ insinto /etc
+ doins ${FILESDIR}/pump.conf
+
+ doman pump.8
+ dodoc COPYING CREDITS
+}