summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjoern Brauel <bjb@gentoo.org>2003-01-06 18:12:33 +0000
committerBjoern Brauel <bjb@gentoo.org>2003-01-06 18:12:33 +0000
commit1c31d2ff29e13f17d310f6d69125cfcd070085c2 (patch)
tree78c33a716659fdce1c0bb993756fe1b51b0176d4 /net-misc/ntp
parentremoved x86 mask (diff)
downloadhistorical-1c31d2ff29e13f17d310f6d69125cfcd070085c2.tar.gz
historical-1c31d2ff29e13f17d310f6d69125cfcd070085c2.tar.bz2
historical-1c31d2ff29e13f17d310f6d69125cfcd070085c2.zip
Add a hack to workaround broken _adjtime guess on alpha
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/ChangeLog6
-rw-r--r--net-misc/ntp/files/ntp-4.1.1b-syscall-libc.patch17
-rw-r--r--net-misc/ntp/ntp-4.1.1b-r3.ebuild3
3 files changed, 24 insertions, 2 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index 743b7bac5001..1c6b156e488a 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-misc/ntp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.17 2003/01/02 03:00:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.18 2003/01/06 18:12:33 bjb Exp $
*ntp-4.1.1b-r3 (31 Dec 2002)
+ 06 Jan 2003; Bjoern Brauel <bjb@gentoo.org> :
+ Added a (nasty) hack for ntp on alpha. configure makes a false assumption
+ about _adjtime on alpha. Fix forces use of libc implementation.
+
01 Jan 2002; Mike Frysinger <vapier@gentoo.org> :
Added a patch to fix the namespace collision with linux include files.
Check Bugs #13001 #6432 #8807
diff --git a/net-misc/ntp/files/ntp-4.1.1b-syscall-libc.patch b/net-misc/ntp/files/ntp-4.1.1b-syscall-libc.patch
new file mode 100644
index 000000000000..48815334315b
--- /dev/null
+++ b/net-misc/ntp/files/ntp-4.1.1b-syscall-libc.patch
@@ -0,0 +1,17 @@
+--- ntp-4.1.1b/include/ntp_syscall.h 2003-01-06 18:51:39.000000000 +0100
++++ ntp-4.1.1b-alpha/include/ntp_syscall.h 2003-01-06 18:54:57.000000000 +0100
+@@ -14,7 +14,6 @@
+ # include <sys/timex.h>
+ #endif
+
+-#ifndef NTP_SYSCALLS_LIBC
+ #ifdef NTP_SYSCALLS_STD
+ # define ntp_adjtime(t) syscall(SYS_ntp_adjtime, (t))
+ # define ntp_gettime(t) syscall(SYS_ntp_gettime, (t))
+@@ -50,6 +49,5 @@
+ # endif
+ # endif /* !HAVE_ADJTIMEX */
+ #endif /* !NTP_SYSCALLS_STD */
+-#endif /* !NTP_SYSCALLS_LIBC */
+
+ #endif /* NTP_SYSCALL_H */
diff --git a/net-misc/ntp/ntp-4.1.1b-r3.ebuild b/net-misc/ntp/ntp-4.1.1b-r3.ebuild
index ec7bf2a442c4..13984711ac8b 100644
--- a/net-misc/ntp/ntp-4.1.1b-r3.ebuild
+++ b/net-misc/ntp/ntp-4.1.1b-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r3.ebuild,v 1.2 2003/01/02 03:00:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r3.ebuild,v 1.3 2003/01/06 18:12:33 bjb Exp $
inherit eutils
@@ -20,6 +20,7 @@ src_unpack() {
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/ntp-bk.diff
epatch ${FILESDIR}/linux-config-phone.patch
+ use alpha && epatch ${FILESDIR}/ntp-4.1.1b-syscall-libc.patch
aclocal -I . || die
automake || die
autoconf || die