summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-12 23:58:49 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-12 23:58:49 +0000
commita05dd41f9334aafdd3d20f9df5eb4b674d2b391a (patch)
treef5e1a17c55906d785fabc6db329ab4a2421217b2 /net-mail
parentdon't default to db for passwd,shadow,compat, use compat instead (diff)
downloadhistorical-a05dd41f9334aafdd3d20f9df5eb4b674d2b391a.tar.gz
historical-a05dd41f9334aafdd3d20f9df5eb4b674d2b391a.tar.bz2
historical-a05dd41f9334aafdd3d20f9df5eb4b674d2b391a.zip
added, if segfaulting, please read my post on gentoo-dev
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/evolution-0.12.ebuild67
-rw-r--r--net-mail/evolution/files/digest-evolution-0.122
2 files changed, 69 insertions, 0 deletions
diff --git a/net-mail/evolution/evolution-0.12.ebuild b/net-mail/evolution/evolution-0.12.ebuild
new file mode 100644
index 000000000000..b8c4fa769206
--- /dev/null
+++ b/net-mail/evolution/evolution-0.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <hallski@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-0.12.ebuild,v 1.1 2001/08/12 23:58:49 hallski Exp $
+
+DB3=db-3.1.17
+A="${P}.tar.gz ${DB3}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/gal-0.10
+ >=gnome-base/gtkhtml-0.11.1
+ >=gnome-libs/bonobo-conf-0.10
+ >=gnome-base/bonobo-1.0.7
+ >=gnome-base/oaf-0.6.5
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/libglade-0.14
+ >=gnome-base/gdk-pixbuf-0.9.0
+ >=gnome-base/libxml-1.8.10
+ >=gnome-base/gnome-vfs-1.0
+ >=gnome-base/gnome-print-0.25
+ >=dev-util/xml-i18n-tools-0.8.4
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+src_compile() {
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ try ../dist/configure --prefix=${WORKDIR}/db3
+ try make # make -j 4 doesn't work, use make
+ try make prefix=${WORKDIR}/db3 install
+
+ cd ${S}
+
+ patch -p0 < ${FILESDIR}/build-evolution-0.12.patch
+
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --enable-ssl"
+ else
+ myconf="$myconf --disable-ssl"
+ fi
+
+ try ./configure --prefix=/opt/gnome --host=${CHOST} \
+ --sysconfdir=/etc/opt/gnome --enable-file-locking=no \
+ --with-db3=${WORKDIR}/db3 --enable-nntp $myconf
+
+ try pmake
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+
diff --git a/net-mail/evolution/files/digest-evolution-0.12 b/net-mail/evolution/files/digest-evolution-0.12
new file mode 100644
index 000000000000..1e1a4e678019
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-0.12
@@ -0,0 +1,2 @@
+MD5 c5224f6dfa1154b3cce7c31d35c7a48f evolution-0.12.tar.gz
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz