summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 20:03:25 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 20:03:25 +0000
commita3aebd80023bd99f116b17c201f38b8e4103cb45 (patch)
tree5a103e7b543683a3cecf8055e7d063055e93625f /net-libs
parentVersion bump. (diff)
downloadhistorical-a3aebd80023bd99f116b17c201f38b8e4103cb45.tar.gz
historical-a3aebd80023bd99f116b17c201f38b8e4103cb45.tar.bz2
historical-a3aebd80023bd99f116b17c201f38b8e4103cb45.zip
Initial commit. Import from kde overlay. Needed for KDE SC 4.9.0.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libkolab/ChangeLog10
-rw-r--r--net-libs/libkolab/files/libkolab-fix-include.patch146
-rw-r--r--net-libs/libkolab/libkolab-0.2.0.ebuild31
-rw-r--r--net-libs/libkolab/metadata.xml5
-rw-r--r--net-libs/libkolabxml/ChangeLog10
-rw-r--r--net-libs/libkolabxml/libkolabxml-0.6.0.ebuild41
-rw-r--r--net-libs/libkolabxml/metadata.xml8
7 files changed, 251 insertions, 0 deletions
diff --git a/net-libs/libkolab/ChangeLog b/net-libs/libkolab/ChangeLog
new file mode 100644
index 000000000000..ecc3b980512d
--- /dev/null
+++ b/net-libs/libkolab/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-libs/libkolab
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolab/ChangeLog,v 1.1 2012/08/01 20:03:24 johu Exp $
+
+*libkolab-0.2.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +libkolab-0.2.0.ebuild,
+ +files/libkolab-fix-include.patch, +metadata.xml:
+ Initial commit. Import from kde overlay. Needed for KDE SC 4.9.0.
+
diff --git a/net-libs/libkolab/files/libkolab-fix-include.patch b/net-libs/libkolab/files/libkolab-fix-include.patch
new file mode 100644
index 000000000000..71dc68410109
--- /dev/null
+++ b/net-libs/libkolab/files/libkolab-fix-include.patch
@@ -0,0 +1,146 @@
+--- conversion/commonconversion.h 2012-05-02 07:56:08.000000000 -0400
++++ conversion/commonconversion.h 2012-07-02 23:04:24.762660720 -0400
+@@ -20,7 +20,7 @@
+
+ #include <KDE/KDateTime>
+ #include <QStringList>
+-#include <kolab/kolabcontainers.h>
++#include <kolabcontainers.h>
+
+
+ namespace Kolab {
+@@ -32,4 +32,4 @@
+ };
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+--- conversion/kabcconversion.h 2012-05-02 07:56:08.000000000 -0400
++++ conversion/kabcconversion.h 2012-07-02 23:04:24.762660720 -0400
+@@ -20,7 +20,7 @@
+
+ #include "kolab_export.h"
+
+-#include <kolab/kolabcontact.h>
++#include <kolabcontact.h>
+ #include <kabc/addressee.h>
+ #include <kabc/contactgroup.h>
+
+@@ -40,4 +40,4 @@
+ };
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+--- conversion/kcalconversion.h 2012-05-02 07:56:08.000000000 -0400
++++ conversion/kcalconversion.h 2012-07-02 23:04:24.763660720 -0400
+@@ -20,9 +20,9 @@
+
+ #include "kolab_export.h"
+
+-#include <kolab/kolabevent.h>
+-#include <kolab/kolabtodo.h>
+-#include <kolab/kolabjournal.h>
++#include <kolabevent.h>
++#include <kolabtodo.h>
++#include <kolabjournal.h>
+ #include <kcalcore/event.h>
+ #include <kcalcore/todo.h>
+ #include <kcalcore/journal.h>
+@@ -49,4 +49,4 @@
+ };
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+--- conversion/kolabconversion.h 2012-05-02 07:56:08.000000000 -0400
++++ conversion/kolabconversion.h 2012-07-02 23:04:24.764660720 -0400
+@@ -20,7 +20,7 @@
+
+ #include "kolab_export.h"
+
+-#include <kolab/kolabnote.h>
++#include <kolabnote.h>
+ #include <kmime/kmime_message.h>
+
+ namespace Kolab {
+@@ -36,4 +36,4 @@
+ };
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+--- kolabformat/errorhandler.cpp 2012-05-02 07:56:08.000000000 -0400
++++ kolabformat/errorhandler.cpp 2012-07-02 23:04:24.764660720 -0400
+@@ -20,7 +20,7 @@
+
+ #include <qdebug.h>
+
+-#include <kolab/kolabformat.h>
++#include <kolabformat.h>
+
+ namespace Kolab {
+
+--- kolabformat/kolabobject.cpp 2012-05-02 07:56:08.000000000 -0400
++++ kolabformat/kolabobject.cpp 2012-07-02 23:04:24.765660720 -0400
+@@ -34,7 +34,7 @@
+ #include <conversion/kabcconversion.h>
+ #include <conversion/kolabconversion.h>
+ #include <akonadi/notes/noteutils.h>
+-#include <kolab/kolabformat.h>
++#include <kolabformat.h>
+
+
+ namespace Kolab {
+--- tests/benchmark.cpp 2012-05-02 07:56:08.000000000 -0400
++++ tests/benchmark.cpp 2012-07-02 23:05:22.746664944 -0400
+@@ -19,7 +19,7 @@
+ #include "kolabformatV2/event.h"
+ #include "conversion/kcalconversion.h"
+ #include <kmime/kmime_message.h>
+-#include <kolab/kolabformat.h>
++#include <kolabformat.h>
+ #include <kdebug.h>
+ #include "testutils.h"
+
+--- tests/formattest.cpp 2012-05-02 07:56:08.000000000 -0400
++++ tests/formattest.cpp 2012-07-02 23:05:34.920665858 -0400
+@@ -26,8 +26,8 @@
+ #include <qtemporaryfile.h>
+ #include <QBuffer>
+ #include <kdebug.h>
+-#include <kolab/kolabcontainers.h>
+-#include <kolab/kolabformat.h>
++#include <kolabcontainers.h>
++#include <kolabformat.h>
+
+ #include <kcalcore/icalformat.h>
+ #include <kabc/vcardconverter.h>
+--- tests/kcalconversiontest.cpp 2012-05-02 07:56:08.000000000 -0400
++++ tests/kcalconversiontest.cpp 2012-07-02 23:05:46.269666653 -0400
+@@ -4,7 +4,7 @@
+ #include <QtCore/QObject>
+ #include <QtTest/QtTest>
+ #include <KDE/KSystemTimeZones>
+-#include <kolab/kolabcontact.h>
++#include <kolabcontact.h>
+ #include <kcalcore/recurrence.h>
+ #include <kabc/addressee.h>
+
+--- tests/upgradetest.cpp 2012-05-02 07:56:08.000000000 -0400
++++ tests/upgradetest.cpp 2012-07-02 23:06:03.269667875 -0400
+@@ -19,8 +19,8 @@
+ #include "upgradetest.h"
+
+ #include <QTest>
+-#include <kolab/kolabcontainers.h>
+-#include <kolab/kolabformat.h>
++#include <kolabcontainers.h>
++#include <kolabformat.h>
+
+ #include "testutils.h"
+ #include "kolabformat/kolabobject.h"
diff --git a/net-libs/libkolab/libkolab-0.2.0.ebuild b/net-libs/libkolab/libkolab-0.2.0.ebuild
new file mode 100644
index 000000000000..85433fa03017
--- /dev/null
+++ b/net-libs/libkolab/libkolab-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolab/libkolab-0.2.0.ebuild,v 1.1 2012/08/01 20:03:24 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Advanced Kolab Object Handling Library"
+HOMEPAGE="kolab.org"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/libkolab-fix-include.patch" )
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ >=net-libs/libkolabxml-0.4.0
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with test BUILD_TESTS)
+ )
+ kde4-base_src_configure
+}
diff --git a/net-libs/libkolab/metadata.xml b/net-libs/libkolab/metadata.xml
new file mode 100644
index 000000000000..8d36d5b01cd2
--- /dev/null
+++ b/net-libs/libkolab/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/net-libs/libkolabxml/ChangeLog b/net-libs/libkolabxml/ChangeLog
new file mode 100644
index 000000000000..b20f9ad46147
--- /dev/null
+++ b/net-libs/libkolabxml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-libs/libkolabxml
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.1 2012/08/01 20:00:09 johu Exp $
+
+*libkolabxml-0.6.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +libkolabxml-0.6.0.ebuild,
+ +metadata.xml:
+ Initial commit. Import from kde overlay. Needed for KDE SC 4.9.0.
+
diff --git a/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild b/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
new file mode 100644
index 000000000000..8dbfa9627fde
--- /dev/null
+++ b/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild,v 1.1 2012/08/01 20:00:09 johu Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Kolab XML format schema definitions library"
+HOMEPAGE="http://www.kolab.org"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="csharp java python php test"
+
+RDEPEND="
+ dev-cpp/xsd
+ || ( >=dev-libs/boost-1.42.0 ( <dev-libs/boost-1.42.0 dev-libs/ossp-uuid ) )
+ dev-libs/xerces-c
+"
+DEPEND="
+ ${RDEPEND}
+ csharp? ( dev-lang/swig )
+ java? ( dev-lang/swig )
+ php? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ test? ( x11-libs/qt-test:4 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use csharp CSHARP_BINDINGS)
+ $(cmake-utils_use java JAVA_BINDINGS)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ $(cmake-utils_use php PHP_BINDINGS)
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-libs/libkolabxml/metadata.xml b/net-libs/libkolabxml/metadata.xml
new file mode 100644
index 000000000000..10fdb56d0071
--- /dev/null
+++ b/net-libs/libkolabxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="csharp">Enable C# language bindings</flag>
+</use>
+</pkgmetadata>