summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-03-02 23:52:33 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-03-02 23:52:33 +0000
commit3e871c5c7cf70a22607286455b408d90486e8312 (patch)
tree9622a725bb8d3f79b56413ecb87583e2d9fb0a1e /net-libs/openh323
parentfinally, a totally working version... removed the old one (diff)
downloadhistorical-3e871c5c7cf70a22607286455b408d90486e8312.tar.gz
historical-3e871c5c7cf70a22607286455b408d90486e8312.tar.bz2
historical-3e871c5c7cf70a22607286455b408d90486e8312.zip
working version
Diffstat (limited to 'net-libs/openh323')
-rw-r--r--net-libs/openh323/files/11openh3232
-rw-r--r--net-libs/openh323/openh323-1.8.0.ebuild22
2 files changed, 13 insertions, 11 deletions
diff --git a/net-libs/openh323/files/11openh323 b/net-libs/openh323/files/11openh323
deleted file mode 100644
index f071efd6e104..000000000000
--- a/net-libs/openh323/files/11openh323
+++ /dev/null
@@ -1,2 +0,0 @@
-OPENH323DIR=/usr/lib/openh323
-LDPATH=/usr/lib/openh323/lib
diff --git a/net-libs/openh323/openh323-1.8.0.ebuild b/net-libs/openh323/openh323-1.8.0.ebuild
index 8bc8d3877717..fb8a99af73fa 100644
--- a/net-libs/openh323/openh323-1.8.0.ebuild
+++ b/net-libs/openh323/openh323-1.8.0.ebuild
@@ -1,31 +1,35 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.8.0.ebuild,v 1.1 2002/03/01 06:50:14 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.8.0.ebuild,v 1.2 2002/03/02 23:52:33 verwilst Exp $
S="${WORKDIR}/openh323"
SRC_URI="http://www.gnomemeeting.org/downloads/latest/sources/openh323_1.8.0-patched.tar.gz"
HOMEPAGE="http://www.openh323.org"
DEPEND="virtual/glibc
- >=dev-libs/pwlib-1.2.1"
+ >=dev-libs/pwlib-1.2.1-r2"
src_compile() {
-
+
cd ${S}
+ export PWLIBDIR=/usr/share/pwlib
export OPENH323DIR=${S}
- make opt || die
+ echo $PWLIBDIR
+
+ make optshared || die
}
src_install() {
- mkdir -p ${D}/etc/env.d
- mkdir -p ${D}/usr/lib/openh323
cd ${S}
- cp -a * ${D}/usr/lib/openh323
- cp ${FILESDIR}/11openh323 ${D}/etc/env.d
-
+ mkdir -p ${D}/usr/lib
+ mkdir -p ${D}/usr/include/openh323
+ cp -d lib/lib* ${D}/usr/lib
+ cp -d include/*.h ${D}/usr/include/openh323
+ cd ${D}/usr/lib
+ ln -sf libh323_linux_x86_r.so.1.0.0a libopenh323.so
}