summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-03-12 15:10:35 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-03-12 15:10:35 +0000
commit0723d1f367deb0f28fd070c7eb2e26ba32385094 (patch)
tree5b20bc08def75410db26ce5ab41004c8b145d882 /net-libs/obby/obby-0.3.0-r1.ebuild
parentnet-libs/obby-0.3.0-r1 (diff)
downloadhistorical-0723d1f367deb0f28fd070c7eb2e26ba32385094.tar.gz
historical-0723d1f367deb0f28fd070c7eb2e26ba32385094.tar.bz2
historical-0723d1f367deb0f28fd070c7eb2e26ba32385094.zip
fix for dual subscribe problem
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'net-libs/obby/obby-0.3.0-r1.ebuild')
-rw-r--r--net-libs/obby/obby-0.3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/obby/obby-0.3.0-r1.ebuild b/net-libs/obby/obby-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..fbbf4b956c41
--- /dev/null
+++ b/net-libs/obby/obby-0.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.3.0-r1.ebuild,v 1.1 2006/03/12 15:10:35 humpback Exp $
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+inherit eutils
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+DEPEND=">=net-libs/net6-1.2.2
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/dual_subscribe.patch
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}