summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-25 00:43:39 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-25 00:43:39 +0000
commit1bee30416768ca59023ff407c286c3aba14ea311 (patch)
tree637a866376ea81d9c95c3dad37dcda10c767004b /net-libs/libnids/libnids-1.20.ebuild
parentMention available documentation, #77309. (diff)
downloadhistorical-1bee30416768ca59023ff407c286c3aba14ea311.tar.gz
historical-1bee30416768ca59023ff407c286c3aba14ea311.tar.bz2
historical-1bee30416768ca59023ff407c286c3aba14ea311.zip
Version bump for bug 81689; also fixed src_install (setting install_prefix to ${D} caused part of ${D} to be installed).
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'net-libs/libnids/libnids-1.20.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.20.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.20.ebuild b/net-libs/libnids/libnids-1.20.ebuild
new file mode 100644
index 000000000000..6cedec1f699f
--- /dev/null
+++ b/net-libs/libnids/libnids-1.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.20.ebuild,v 1.1 2005/02/25 00:43:39 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+HOMEPAGE="http://libnids.sourceforget.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="virtual/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-chksum.c-ebx.patch
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ make || die "emake failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+ dodoc CHANGES COPYING CREDITS MISC README
+}