summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-25 15:11:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-25 15:11:56 +0000
commit2411b5f4ed3482776f2c95659246b642055dc8c1 (patch)
treed46a6ca5de9f4635f3af826ed8a6541c553de995 /net-libs/liblockfile/liblockfile-1.06.ebuild
parentUse bindnow-flags function instead of -Wl,-z,now. (diff)
downloadhistorical-2411b5f4ed3482776f2c95659246b642055dc8c1.tar.gz
historical-2411b5f4ed3482776f2c95659246b642055dc8c1.tar.bz2
historical-2411b5f4ed3482776f2c95659246b642055dc8c1.zip
Use bindnow-flags function instead of -Wl,-z,now.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'net-libs/liblockfile/liblockfile-1.06.ebuild')
-rw-r--r--net-libs/liblockfile/liblockfile-1.06.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/liblockfile/liblockfile-1.06.ebuild b/net-libs/liblockfile/liblockfile-1.06.ebuild
index 7e4217fbf78a..c14476938cc1 100644
--- a/net-libs/liblockfile/liblockfile-1.06.ebuild
+++ b/net-libs/liblockfile/liblockfile-1.06.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.06.ebuild,v 1.10 2005/08/10 11:24:51 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.06.ebuild,v 1.11 2005/12/25 15:11:56 flameeyes Exp $
-inherit eutils multilib
+inherit eutils multilib flag-o-matic
DESCRIPTION="Implements functions designed to lock the standard mailboxes."
SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.tar.gz"
@@ -17,7 +17,7 @@ IUSE=""
src_compile() {
# Do not use lazy bindings on setXid files
- sed -i -e 's~-o dotlockfile~-Wl,-z,now &~g' Makefile.in
+ sed -i -e 's~-o dotlockfile~'$(bindnow-flags)' &~g' Makefile.in
econf --with-mailgroup=mail --enable-shared || die
emake || die
}