summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-09-17 13:08:50 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-09-17 13:08:50 +0000
commitdd18115518a304edfc0c552231156249ddc811c4 (patch)
treeb6905f727561ede20788812703578c49e63ca4d9 /net-libs/libetpan
parentUTF-8 fixes. (diff)
downloadhistorical-dd18115518a304edfc0c552231156249ddc811c4.tar.gz
historical-dd18115518a304edfc0c552231156249ddc811c4.tar.bz2
historical-dd18115518a304edfc0c552231156249ddc811c4.zip
Version bump. Added sasl and gnutls USE flags.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog7
-rw-r--r--net-libs/libetpan/Manifest10
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.391
-rw-r--r--net-libs/libetpan/libetpan-0.39.ebuild35
4 files changed, 48 insertions, 5 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index f4d7f1d91a77..be2e1582f564 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.10 2005/08/23 15:19:47 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.11 2005/09/17 13:08:50 ticho Exp $
+
+*libetpan-0.39 (17 Sep 2005)
+
+ 17 Sep 2005; Andrej Kacian <ticho@gentoo.org> +libetpan-0.39.ebuild:
+ Version bump. Added sasl and gnutls USE flags.
23 Aug 2005; Andrej Kacian <ticho@gentoo.org> -libetpan-0.36.ebuild,
-libetpan-0.37.ebuild, libetpan-0.38.ebuild:
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index ee219de915cb..eeac325a3480 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -2,13 +2,15 @@
Hash: SHA1
MD5 3c26af9390d1cdbe31ff6a7d7aeac5c9 libetpan-0.38.ebuild 822
-MD5 5c4d16f58addf6ec9548739067ee4f6b ChangeLog 1130
+MD5 f6e76d294861780198eb79aaf3c4f4b1 libetpan-0.39.ebuild 954
+MD5 a83f70e479c824965b43941fcd2718f3 ChangeLog 1281
MD5 509fe3ad1d5f4dfbeab7ff814984a262 metadata.xml 612
MD5 364e68999c2cd29fbe9da07eb967855b files/digest-libetpan-0.38 66
+MD5 46fdbe475507d8131713621e1ab81620 files/digest-libetpan-0.39 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDCz6vQlM6RnzZP+IRAoK3AJwKavDzfv616E6VmigWwu3yyYI/vgCgptYH
-yoOlmeCOUCvWF4W7Iq7wAwc=
-=fc9S
+iD8DBQFDLBWbQlM6RnzZP+IRAqdEAJ44WppmlKRBNui0ccGptdcGMM654wCgt69r
+gaRAGowINyKoWXLcd9UpNjs=
+=6qXr
-----END PGP SIGNATURE-----
diff --git a/net-libs/libetpan/files/digest-libetpan-0.39 b/net-libs/libetpan/files/digest-libetpan-0.39
new file mode 100644
index 000000000000..0c30626252f0
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.39
@@ -0,0 +1 @@
+MD5 d4659640999458a816a4e48c15653420 libetpan-0.39.tar.gz 1115262
diff --git a/net-libs/libetpan/libetpan-0.39.ebuild b/net-libs/libetpan/libetpan-0.39.ebuild
new file mode 100644
index 000000000000..bc0efad1217e
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.39.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.39.ebuild,v 1.1 2005/09/17 13:08:50 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="berkdb debug gnutls sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local myconf
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with gnutls` \
+ `use_with ssl openssl` \
+ `use_with sasl` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}