summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-04-04 20:18:33 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-04-04 20:18:33 +0000
commit75feb557a7770919eb6b04d64f5ba376b9c29d03 (patch)
tree48209bdcef4fa38fa5e8de0e73a666d0dd76d604 /net-im
parentchangelogs updated for kde3 (diff)
downloadhistorical-75feb557a7770919eb6b04d64f5ba376b9c29d03.tar.gz
historical-75feb557a7770919eb6b04d64f5ba376b9c29d03.tar.bz2
historical-75feb557a7770919eb6b04d64f5ba376b9c29d03.zip
Added patch to fix bug #1479.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog9
-rw-r--r--net-im/licq/files/digest-licq-1.0.4-r21
-rw-r--r--net-im/licq/licq-1.0.4-r2.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 6d516b6acd98..39dd6438ea8b 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.2 2002/04/04 20:18:33 g2boojum Exp $
+*licq-1.0.4-r2 (4 Apr 2002)
+
+ 4 Apr 2002; Grant Goodyear <g2boojum@gentoo.org> :
+
+ Added patch from Paul de Vrieze to fix the problem that
+ kdeconf resets the cwd (to ${S}?).
+
*licq-1.0.4-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-im/licq/files/digest-licq-1.0.4-r2 b/net-im/licq/files/digest-licq-1.0.4-r2
new file mode 100644
index 000000000000..b93adbc0a209
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.0.4-r2
@@ -0,0 +1 @@
+MD5 df3e50c1b03aa0cf2ecd1c27af3588e7 licq-1.0.4.tar.bz2 1717078
diff --git a/net-im/licq/licq-1.0.4-r2.ebuild b/net-im/licq/licq-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..9bfc9a4ac35b
--- /dev/null
+++ b/net-im/licq/licq-1.0.4-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4-r2.ebuild,v 1.1 2002/04/04 20:18:33 g2boojum Exp $
+. /usr/portage/eclass/inherit.eclass || die
+use kde && inherit kde-base
+
+S=${WORKDIR}/${P}
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+DESCRIPTION="KDE/QT ICQ Client with v6 support only (UDP)"
+SLOT="0"
+DEPEND="$DEPEND
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-2.2.0 )"
+
+use kde && need-kde 2.1
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+}
+
+src_compile() {
+ local first_conf
+
+ cd ${S}
+ make -f Makefile.cvs || die
+
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+ # note! watch the --prefix=/usr placement; licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns) installs its files in
+ # $KDE2DIR/{lib,share}/licq
+ cd plugins/qt-gui-1.0.4
+ make -f Makefile.cvs || die
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.0.4
+ make DESTDIR=${D} install || die
+ fi
+
+}