summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-09 19:13:24 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-09 19:13:24 +0000
commitd4b599f027da34e005315905cc65502edb0f2aac (patch)
treebfde3eda40619db179ee61f62fcbdcd7024fc91f /net-im/licq
parentnew multi-kdedirs support. see anouncement on gentoo-* in 5 minutes. enjoy! (diff)
downloadhistorical-d4b599f027da34e005315905cc65502edb0f2aac.tar.gz
historical-d4b599f027da34e005315905cc65502edb0f2aac.tar.bz2
historical-d4b599f027da34e005315905cc65502edb0f2aac.zip
new multi-kdedirs support. see anouncement on gentoo-* in 5 minutes. enjoy!
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/files/digest-licq-1.0.4-r11
-rw-r--r--net-im/licq/licq-1.0.4-r1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/licq/files/digest-licq-1.0.4-r1 b/net-im/licq/files/digest-licq-1.0.4-r1
new file mode 100644
index 000000000000..827ef1fcfd0d
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.0.4-r1
@@ -0,0 +1 @@
+MD5 df3e50c1b03aa0cf2ecd1c27af3588e7 licq-1.0.4.tar.bz2 1720320
diff --git a/net-im/licq/licq-1.0.4-r1.ebuild b/net-im/licq/licq-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..b1bde3ea7df4
--- /dev/null
+++ b/net-im/licq/licq-1.0.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4-r1.ebuild,v 1.1 2002/01/09 19:13:24 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+use kde && inherit kde-base
+
+S=${WORKDIR}/${P}
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+DESCRIPTION="KDE/QT ICQ Client with v6 support only (UDP)"
+
+DEPEND="$DEPEND
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+use kde && need-kde 2.1
+use kde && need-qt 2.2.2
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+}
+
+src_compile() {
+ local first_conf
+
+ cd ${S}
+ make -f Makefile.cvs || die
+
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+
+ export QTDIR=/usr/qt/2
+ cd plugins/qt-gui-1.0.4
+ make -f Makefile.cvs || die
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+ # note! watch the --prefix=/usr placement; licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns) installs its files in
+ # $KDE2DIR/{lib,share}/licq
+ ./configure --host=${CHOST} --prefix=/usr ${second_conf} || die
+ emake || die
+
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.0.4
+ make DESTDIR=${D} install || die
+ fi
+
+}