summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-24 17:16:33 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-24 17:16:33 +0000
commitb1ad96828de9af96f16de6d971a6e254c7457841 (patch)
treeb88e87e17aec08cc46ed037971b3fc39bbdfeaaa /net-fs
parentAdded autoconf for ldap. Closes #27369. (diff)
downloadhistorical-b1ad96828de9af96f16de6d971a6e254c7457841.tar.gz
historical-b1ad96828de9af96f16de6d971a6e254c7457841.tar.bz2
historical-b1ad96828de9af96f16de6d971a6e254c7457841.zip
Added autoconf for ldap. Closes #27369.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/Manifest5
-rw-r--r--net-fs/autofs/autofs-3.1.7-r6.ebuild71
-rw-r--r--net-fs/autofs/files/digest-autofs-3.1.7-r61
3 files changed, 75 insertions, 2 deletions
diff --git a/net-fs/autofs/Manifest b/net-fs/autofs/Manifest
index 1a477a1d18f2..9848b65cade7 100644
--- a/net-fs/autofs/Manifest
+++ b/net-fs/autofs/Manifest
@@ -1,7 +1,8 @@
-MD5 69f5df0cb3617f616a3f25eadb5e0b01 ChangeLog 3380
+MD5 2894baa3b2030e5234331b55fa68181c ChangeLog 3530
MD5 70a328a7cb89310eeb6ec33c609a3107 autofs-3.1.7-r3.ebuild 1313
MD5 2c8659ab995069a50b2ed53da5f4e936 autofs-3.1.7-r4.ebuild 1750
-MD5 cd00ffb46652aeb90cad821c5a50ed77 autofs-3.1.7-r6.ebuild 1796
+MD5 4c3981d85d49586fe99bd5744de29318 autofs-3.1.7-r6.ebuild 1794
+MD5 57d0455e83cfef78f78092ad5a181c52 autofs-3.1.7-r5.ebuild 1772
MD5 256e713e8b47896dd2049326ec26fc78 files/auto.home 239
MD5 7dfc74b098600c091681c950b67b1022 files/auto.master 237
MD5 aa40e8bef91418943312910e73d05eed files/auto.misc 319
diff --git a/net-fs/autofs/autofs-3.1.7-r6.ebuild b/net-fs/autofs/autofs-3.1.7-r6.ebuild
new file mode 100644
index 000000000000..3e041ad435e8
--- /dev/null
+++ b/net-fs/autofs/autofs-3.1.7-r6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7-r6.ebuild,v 1.1 2003/09/24 17:16:28 mholzer Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI="mirror://kernel/linux/daemons/${PN}/${P}.tar.bz2"
+
+DEPEND="ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ldap_config.patch || die "ldap patch died"
+
+ cd ${S}/include
+ epatch ${FILESDIR}/automount.diff || die "automount patch died"
+
+ cd ${S}
+ autoconf
+
+ cd ${S}/daemon
+ sed -i 's/LIBS \= \-ldl/LIBS \= \-ldl \-lnsl \$\{LIBLDAP\}/' Makefile
+}
+
+src_compile() {
+ local myconf
+ use ldap || myconf="--without-openldap"
+
+ ./configure \
+ --host=${HOST} \
+ --prefix=/usr \
+ ${myconf} || die
+ make || die "make failed"
+}
+
+src_install() {
+ into /usr
+ dosbin daemon/automount
+ insinto /usr/lib/autofs
+ insopts -m 755
+ doins modules/*.so
+
+ dodoc COPYING COPYRIGHT NEWS README* TODO
+ cd man
+ doman auto.master.5 autofs.5 autofs.8 automount.8
+
+ cd ../samples
+ dodir /etc/autofs
+ cp ${FILESDIR}/auto.master ${D}/etc/autofs
+ cp ${FILESDIR}/auto.misc ${D}/etc/autofs
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/autofs.rc8 autofs
+ insinto /etc/conf.d ; newins ${FILESDIR}/autofs.confd autofs
+}
+
+pkg_postinst() {
+ einfo "Note: If you plan on using autofs for automounting"
+ einfo "remote NFS mounts without having the NFS daemon running"
+ einfo "please add portmap to your default run-level."
+ echo ""
+ einfo "Also the normal autofs status has been renamed stats"
+ einfo "as there is already a predefined Gentoo status"
+}
diff --git a/net-fs/autofs/files/digest-autofs-3.1.7-r6 b/net-fs/autofs/files/digest-autofs-3.1.7-r6
new file mode 100644
index 000000000000..c8410dc43753
--- /dev/null
+++ b/net-fs/autofs/files/digest-autofs-3.1.7-r6
@@ -0,0 +1 @@
+MD5 4f602f82442b48ce9c2e0005d59c3408 autofs-3.1.7.tar.bz2 57000