summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-02-12 16:36:27 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-02-12 16:36:27 +0000
commit8e695a98a4cdb960b233e33f65ebbda08fb9cbc4 (patch)
tree18ed63b09ad6de76531737865c078cb7cd27e3af /net-firewall/shorewall6
parentAutomated update of use.local.desc (diff)
downloadhistorical-8e695a98a4cdb960b233e33f65ebbda08fb9cbc4.tar.gz
historical-8e695a98a4cdb960b233e33f65ebbda08fb9cbc4.tar.bz2
historical-8e695a98a4cdb960b233e33f65ebbda08fb9cbc4.zip
Version bump
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/shorewall6-4.4.17.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index cc5e0dc6e436..820e0beb70b7 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.25 2011/01/26 19:50:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.26 2011/02/12 16:35:48 constanze Exp $
+
+*shorewall6-4.4.17 (12 Feb 2011)
+
+ 12 Feb 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.4.17.ebuild:
+ Version bump
26 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
shorewall6-4.4.15.1.ebuild:
diff --git a/net-firewall/shorewall6/shorewall6-4.4.17.ebuild b/net-firewall/shorewall6/shorewall6-4.4.17.ebuild
new file mode 100644
index 000000000000..5ee2dfd232e5
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.4.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.4.17.ebuild,v 1.1 2011/02/12 16:35:48 constanze Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10+ and must emerge dev-perl/Socket6."
+}