summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Cox <steel300@gentoo.org>2004-04-14 02:27:05 +0000
committerJason Cox <steel300@gentoo.org>2004-04-14 02:27:05 +0000
commit8bff4640ce1b25d47131c30edaa23d295efc5165 (patch)
tree9855b425bbb5155704f01877f835442fc4bbca80 /net-dialup/speedtouch/speedtouch-1.2.ebuild
parentVersion bump, closes #47712. Removed the nls comments, seems to be working now. (diff)
downloadhistorical-8bff4640ce1b25d47131c30edaa23d295efc5165.tar.gz
historical-8bff4640ce1b25d47131c30edaa23d295efc5165.tar.bz2
historical-8bff4640ce1b25d47131c30edaa23d295efc5165.zip
Version Bump.
Diffstat (limited to 'net-dialup/speedtouch/speedtouch-1.2.ebuild')
-rw-r--r--net-dialup/speedtouch/speedtouch-1.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-dialup/speedtouch/speedtouch-1.2.ebuild b/net-dialup/speedtouch/speedtouch-1.2.ebuild
new file mode 100644
index 000000000000..7196fffb4d8d
--- /dev/null
+++ b/net-dialup/speedtouch/speedtouch-1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.2.ebuild,v 1.1 2004/04/14 02:27:05 steel300 Exp $
+
+inherit flag-o-matic
+filter-flags -mpowerpc-gfxopt -mpowerpc-gpopt
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GPL Driver for the Alcatel Speedtouch USB under *nix"
+HOMEPAGE="http://speedtouch.sf.net/"
+SRC_URI="mirror://sourceforge/speedtouch/${MY_P}.tar.bz2"
+
+IUSE="static debug"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~hppa ~amd64"
+
+DEPEND=""
+RDEPEND=">=net-dialup/ppp-2.4.1"
+
+src_compile() {
+ use debug && myconf="--enable-debug"
+ use static && myconf="${myconf} --enable-static"
+
+ econf --enable-syslog \
+ ${myconf} || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die
+
+ # twp 2003-12-25 install *.html correctly
+ find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs dohtml
+ find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs rm
+ echo $(find ${D}/usr/share/doc/speedtouch/ -type f) | xargs dodoc
+ rm -rf ${D}/usr/share/doc/speedtouch/
+ dodoc AUTHORS COPYING ChangeLog INSTALL TODO VERSION
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/speedtouch.rc6 speedtouch
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/speedtouch.confd speedtouch
+
+ insopts -m 600 ; insinto /etc/ppp/peers ; doins ${FILESDIR}/adsl.sample
+
+ dosbin doc-linux/adsl-conf-pppd
+}
+
+pkg_postinst() {
+ echo ""
+ ewarn "Make sure you have kernel support for USB, HDCL and PPP"
+ ewarn "NB: kernels >= 2.4.18 include the hdlc patch"
+ echo ""
+ ewarn "Read and subscribe vendor's licence to download the microcode"
+ ewarn "You can get it from: "
+ ewarn " 1) vendor's site: http://www.speedtouchdsl.com/dvrreg_lx.htm"
+ ewarn " 2) a windows system: c:\windows\system\alcaudsl.sys"
+ ewarn " 3) the CD provided: X:\Driver\alcaudsl.sys"
+ ewarn "Then you should set its path in the /etc/conf.d/speedtouch file"
+ ewarn "edit and rename 'adsl.sample' to 'adsl' in /etc/ppp/peers/adsl and"
+ ewarn "bring up your adsl line using the /etc/init.d/speedtouch script"
+ echo ""
+ einfo "More info in the documentation in /usr/share/doc/${P}"
+ echo ""
+ einfo "You need to pass -a /usr/share/speedtouch/boot.v123.bin to"
+ einfo "modem_run with this version. The URL for firmware is:"
+ einfo "http://www.speedtouchdsl.com/driver_upgrade_lx_3.0.1.2.htm"
+ echo ""
+}