summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 14:35:36 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 14:35:36 +0000
commit3550f9c64b1ec27d0f48cd23391d62600c6cd335 (patch)
tree74710984161636ae74c98462df7244475eded513 /net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild
parentalpha/ia64/sparc stable wrt #207663 (diff)
downloadhistorical-3550f9c64b1ec27d0f48cd23391d62600c6cd335.tar.gz
historical-3550f9c64b1ec27d0f48cd23391d62600c6cd335.tar.bz2
historical-3550f9c64b1ec27d0f48cd23391d62600c6cd335.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild')
-rw-r--r--net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild b/net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild
new file mode 100644
index 000000000000..736efde43763
--- /dev/null
+++ b/net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fxusb_CZ/fxusb_CZ-0.1-r1.ebuild,v 1.1 2008/01/30 14:35:36 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!X USB (Teledat Version)"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack fxusb.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt README*
+ dohtml *.html
+}