summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-13 17:21:44 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-13 17:21:44 +0000
commit41fb467cea1b4999161e956918c729dc727b7111 (patch)
tree902cae624665e5d3d6546f6f6a08bbe8eafa3456 /net-analyzer
parentAdded !virtual/mailx to DEPEND, since we provide it. (diff)
downloadhistorical-41fb467cea1b4999161e956918c729dc727b7111.tar.gz
historical-41fb467cea1b4999161e956918c729dc727b7111.tar.bz2
historical-41fb467cea1b4999161e956918c729dc727b7111.zip
fix #63888 to compile with pcap correctly
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpslice/ChangeLog5
-rw-r--r--net-analyzer/tcpslice/Manifest14
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild10
3 files changed, 14 insertions, 15 deletions
diff --git a/net-analyzer/tcpslice/ChangeLog b/net-analyzer/tcpslice/ChangeLog
index 3f5b0e4f8c6c..dfe44313a806 100644
--- a/net-analyzer/tcpslice/ChangeLog
+++ b/net-analyzer/tcpslice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/tcpslice
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.6 2004/07/10 11:19:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.7 2004/09/13 17:21:44 squinky86 Exp $
+
+ 13 Sep 2004; Jon Hood <squinky86@gentoo.org> tcpslice-1.1_alpha3.ebuild:
+ Compile correctly with pcap, bug #63888.
10 Jul 2004; Eldad Zack <eldad@gentoo.org> tcpslice-1.1_alpha3.ebuild:
Changed to mirror://debian
diff --git a/net-analyzer/tcpslice/Manifest b/net-analyzer/tcpslice/Manifest
index 4dba6dfe4bd2..6f8c798208d2 100644
--- a/net-analyzer/tcpslice/Manifest
+++ b/net-analyzer/tcpslice/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 98fc75c8fdddf5cc42db9bec4dce4373 tcpslice-1.1_alpha3.ebuild 1111
-MD5 110223342e7b2de3108486669528f8c6 ChangeLog 746
+MD5 ce1d674f81fc42d044f5295d03914f43 tcpslice-1.1_alpha3.ebuild 1221
+MD5 db32233cb6e5bc314be56208f6434fe5 ChangeLog 869
MD5 50f280bced8e4dcee548ea16d5e11dc3 metadata.xml 351
MD5 169f554c588ee6189a800e3355f66d24 files/digest-tcpslice-1.1_alpha3 140
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBKhHDT+MN7JbqCpMRAgFBAJ4wVZ2Ao0s6HQnJx0297tD0FIjT1wCeIsqy
-92G36ZIjWb70wU73u1tmyC8=
-=6FmT
------END PGP SIGNATURE-----
diff --git a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
index 4119a2287c78..440e9e311383 100644
--- a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
+++ b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.7 2004/07/10 11:19:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.8 2004/09/13 17:21:44 squinky86 Exp $
inherit eutils
@@ -18,14 +18,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/libc
+
+RDEPEND="virtual/libc
>=net-libs/libpcap-0.6.2-r1"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
S=${WORKDIR}/tcpslice-1.1a3
src_unpack() {
unpack ${A}
epatch ${DISTDIR}/tcpslice_1.1a3-1.1.diff.gz
+ cd ${S}
+ sed -i -e 's:net/bpf.h:pcap-bpf.h:g' tcpslice.c || die
}
src_compile() {