summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-04-19 00:31:08 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-04-19 00:31:08 +0000
commitbb69832922c67d5ee6469b82e966b6e0e8b79b6b (patch)
treeb16f6f704165d12bd3f54d0f1b1789f347202d17 /net-analyzer/nsat/nsat-1.5.ebuild
parentSet MACHINE correctly depending on CTARGET. (diff)
downloadhistorical-bb69832922c67d5ee6469b82e966b6e0e8b79b6b.tar.gz
historical-bb69832922c67d5ee6469b82e966b6e0e8b79b6b.tar.bz2
historical-bb69832922c67d5ee6469b82e966b6e0e8b79b6b.zip
Add patch to fix lvalue error when compiling with gcc4. Fixes bug 128204, thanks to Robert Marmorstein <rmmarm at wm dot edu>. Also, do not install LICENSE.
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-analyzer/nsat/nsat-1.5.ebuild')
-rw-r--r--net-analyzer/nsat/nsat-1.5.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-analyzer/nsat/nsat-1.5.ebuild b/net-analyzer/nsat/nsat-1.5.ebuild
index e5bb5bc4d31d..bd0b742adc0d 100644
--- a/net-analyzer/nsat/nsat-1.5.ebuild
+++ b/net-analyzer/nsat/nsat-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/nsat-1.5.ebuild,v 1.13 2006/02/15 23:37:24 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/nsat-1.5.ebuild,v 1.14 2006/04/19 00:31:08 vanquirius Exp $
inherit eutils
@@ -14,18 +14,20 @@ KEYWORDS="~ppc ~sparc x86"
IUSE="X"
RDEPEND="X? ( || ( x11-libs/libX11 virtual/x11 )
- dev-lang/tk )
+ dev-lang/tk )
net-libs/libpcap"
DEPEND="$RDEPEND >=sys-devel/autoconf-2.58"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+ # bug 128204
+ epatch "${FILESDIR}"/${P}-lvalue-gcc4.patch
sed -i "s:^#CGIFile /usr/local/share/nsat/nsat.cgi$:#CGIFile /usr/share/nsat/nsat.cgi:g" \
nsat.conf
@@ -55,6 +57,6 @@ src_install () {
insinto /etc/nsat
doins nsat.conf
- dodoc README doc/LICENSE doc/CHANGES
+ dodoc README doc/CHANGES
doman doc/nsat.8
}