summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 17:18:37 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 17:18:37 +0000
commit43b9b00be4a9595cf6939a739670db143d07c68e (patch)
tree0c6ef0406f7822cfdbc2c973307865cf3291cb91 /media-video/ogle-gui
parenttypo in network stop code (diff)
downloadhistorical-43b9b00be4a9595cf6939a739670db143d07c68e.tar.gz
historical-43b9b00be4a9595cf6939a739670db143d07c68e.tar.bz2
historical-43b9b00be4a9595cf6939a739670db143d07c68e.zip
Add a fix for libxml2 header change
Add a fix to ogle-gui for libxml2 headers
Diffstat (limited to 'media-video/ogle-gui')
-rw-r--r--media-video/ogle-gui/ogle-gui-0.8.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-video/ogle-gui/ogle-gui-0.8.2-r1.ebuild b/media-video/ogle-gui/ogle-gui-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..dff6b5a9f4de
--- /dev/null
+++ b/media-video/ogle-gui/ogle-gui-0.8.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle-gui/ogle-gui-0.8.2-r1.ebuild,v 1.1 2002/03/25 17:18:37 spider Exp $
+
+P="ogle_gui-0.8.2"
+S=${WORKDIR}/${P}
+DESCRIPTION="GUI interface for the Ogle DVD player"
+SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
+HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
+
+DEPEND=">=media-video/ogle-0.8.2 x11-libs/gtk+ dev-libs/libxml2 sys-devel/bison nls? ( sys-devel/gettext ) gnome-base/libglade"
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="--disable-nls"
+
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
+ CXXFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+
+}
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info docdir=${D}/usr/share/doc/${PF}/html sysconfdir=${D}/etc install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING INSTALL NEWS README
+}
+