summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-04-24 16:26:46 +0000
committerStanislav Brabec <utx@gentoo.org>2003-04-24 16:26:46 +0000
commitf59e73ca03c84c8937b588536c299350d48ef3d2 (patch)
treeffbf3424abe8d0da2ca7d4a7d00bf6ea617b4253 /media-sound/vkeybd
parentfixed DEPEND for tk-8.4 (diff)
downloadhistorical-f59e73ca03c84c8937b588536c299350d48ef3d2.tar.gz
historical-f59e73ca03c84c8937b588536c299350d48ef3d2.tar.bz2
historical-f59e73ca03c84c8937b588536c299350d48ef3d2.zip
limit ladcca support to ladcca-0.1, simplified ebuild
Diffstat (limited to 'media-sound/vkeybd')
-rw-r--r--media-sound/vkeybd/ChangeLog5
-rw-r--r--media-sound/vkeybd/vkeybd-0.1.13.ebuild10
2 files changed, 8 insertions, 7 deletions
diff --git a/media-sound/vkeybd/ChangeLog b/media-sound/vkeybd/ChangeLog
index 9101b5e6de6e..2b500cbf03f0 100644
--- a/media-sound/vkeybd/ChangeLog
+++ b/media-sound/vkeybd/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for media-sound/vkeybd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vkeybd/ChangeLog,v 1.5 2003/04/22 17:45:46 utx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vkeybd/ChangeLog,v 1.6 2003/04/24 16:26:46 utx Exp $
*vkeybd-0.1.13 (22 Apr 2003)
+ 24 Apr 2003; Stanislav Brabec <utx@gentoo.org> vkeybd-0.1.13.ebuild:
+ Limit ladcca support to media-libs/ladcca-0.1. Simplified ebuild.
+
22 Apr 2003; Stanislav Brabec <utx@gentoo.org> vkeybd-0.1.13.ebuild,
files/vkeybd-0.1.13-Makefile.passvariables.patch:
Updated to version 0.1.13, fixed bug #19557.
diff --git a/media-sound/vkeybd/vkeybd-0.1.13.ebuild b/media-sound/vkeybd/vkeybd-0.1.13.ebuild
index ddf0ebb416db..c9225fa19fc2 100644
--- a/media-sound/vkeybd/vkeybd-0.1.13.ebuild
+++ b/media-sound/vkeybd/vkeybd-0.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vkeybd/vkeybd-0.1.13.ebuild,v 1.1 2003/04/22 17:45:46 utx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vkeybd/vkeybd-0.1.13.ebuild,v 1.2 2003/04/24 16:26:46 utx Exp $
DESCRIPTION="A virtual MIDI keyboard for X."
HOMEPAGE="http://www.alsa-project.org/~iwai/alsa.html"
@@ -14,7 +14,7 @@ DEPEND="alsa? ( >=media-libs/alsa-lib-0.5.0 )
>=dev-lang/tk-8.3
>=dev-lang/tcl-8.3
virtual/x11
- ladcca? ( media-libs/ladcca )"
+ ladcca? ( =media-libs/ladcca-0.1 )"
SRC_URI="http://www.alsa-project.org/~iwai/${P}.tar.gz"
S=${WORKDIR}/${PN}
@@ -31,15 +31,13 @@ src_compile() {
local myconf="PREFIX=/usr"
#vkeybd requires at least one of its USE_ variable to be set
- if [ "`use alsa`" ]; then
+ if use alsa ; then
myconf="${myconf} USE_ALSA=1"
use oss || myconf="${myconf} USE_AWE=0 USE_MIDI=0"
else
myconf="${myconf} USE_ALSA=0 USE_AWE=1 USE_MIDI=1"
fi
- if [ "`use ladcca`" ]; then
- myconf="${myconf} USE_LADCCA=1"
- fi
+ use ladcca && myconf="${myconf} USE_LADCCA=1"
make ${myconf} TCL_VERSION=$TCL_VERSION || die "Make failed."
}