summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2006-07-08 22:51:34 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2006-07-08 22:51:34 +0000
commit8451029cc21fe4a144d0383798bf015f86839cf8 (patch)
tree19a1f87a326738894d724c7cfe0e4dcd5b0b34e9 /media-sound/swami/swami-0.9.4.ebuild
parentsplit USE='tcltk' to 'tcl' & 'tk' per bug #17808. (diff)
downloadhistorical-8451029cc21fe4a144d0383798bf015f86839cf8.tar.gz
historical-8451029cc21fe4a144d0383798bf015f86839cf8.tar.bz2
historical-8451029cc21fe4a144d0383798bf015f86839cf8.zip
Version bump to 0.9.4. Thanks to Josh Green <jgreen@users.sourceforge.net>. Closes bug #115941.
Package-Manager: portage-2.1.1_pre2-r4
Diffstat (limited to 'media-sound/swami/swami-0.9.4.ebuild')
-rw-r--r--media-sound/swami/swami-0.9.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/swami/swami-0.9.4.ebuild b/media-sound/swami/swami-0.9.4.ebuild
new file mode 100644
index 000000000000..2e19dd57ca4b
--- /dev/null
+++ b/media-sound/swami/swami-0.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/swami/swami-0.9.4.ebuild,v 1.1 2006/07/08 22:51:34 fvdpol Exp $
+
+IUSE="alsa"
+
+inherit eutils
+
+DESCRIPTION="Sampled Waveforms And Musical Instruments - is an instrument editor for MIDI music composition and a sampler frontend"
+HOMEPAGE="http://swami.sourceforge.net/"
+SRC_URI="http://ovh.dl.sourceforge.net/sourceforge/swami/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+# Swami plugins must not be stripped of symbols, so we handle it manually.
+RESTRICT="nostrip"
+
+RDEPEND="
+ >=x11-libs/gtk+-1.2.10-r11
+ >=media-sound/fluidsynth-1.0.4
+ >=media-libs/audiofile-0.2.0-r1
+ >=media-libs/libsndfile-1.0.0
+ dev-util/pkgconfig
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR="${D}" PREFIX=/usr install || die "install failed"
+}