summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-11-12 19:36:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-11-12 19:36:29 +0000
commit6cc4a4f660d3694d24fe18358115785bd9bdb55b (patch)
tree69a0f92608aa59c440b1d0f7d65a0bd0efd2229b /media-sound/muse/muse-0.9.2.ebuild
parentMarked stable on x86. (diff)
downloadhistorical-6cc4a4f660d3694d24fe18358115785bd9bdb55b.tar.gz
historical-6cc4a4f660d3694d24fe18358115785bd9bdb55b.tar.bz2
historical-6cc4a4f660d3694d24fe18358115785bd9bdb55b.zip
Version bump, wrt to bug #122409
Package-Manager: portage-2.1.2_rc1-r6
Diffstat (limited to 'media-sound/muse/muse-0.9.2.ebuild')
-rw-r--r--media-sound/muse/muse-0.9.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/muse/muse-0.9.2.ebuild b/media-sound/muse/muse-0.9.2.ebuild
new file mode 100644
index 000000000000..c1cc83083717
--- /dev/null
+++ b/media-sound/muse/muse-0.9.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/muse-0.9.2.ebuild,v 1.1 2006/11/12 19:36:29 aballier Exp $
+
+inherit eutils
+
+MY_P=${PN/muse/MuSE}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
+SRC_URI="ftp://ftp.dyne.org/muse/releases/${MY_P}.tar.gz"
+HOMEPAGE="http://muse.dyne.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk debug"
+
+DEPEND="media-sound/lame
+ media-libs/libvorbis
+ media-libs/libsndfile
+ media-libs/libogg
+ sys-libs/zlib
+ sys-apps/sed
+ gtk? ( =x11-libs/gtk+-2*
+ >=dev-libs/glib-2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gtk gtk2) \
+ || die "econf failed"
+
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS} -fpermissive" \
+ || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ rm -rf ${D}/usr/doc
+ dodoc AUTHORS ChangeLog NEWS README TODO KNOWN-BUGS USAGE
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You may want to have a look at /usr/share/doc/${PF}/README.gz"
+ einfo "for more info."
+ einfo
+}