summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-09 18:25:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-09 18:25:54 +0000
commit55dfd922dcef445642f8c69a18a4c92673d3bc54 (patch)
treece779b4ae8a664069066bfe21a2e5e86b7753882 /media-sound/lash/files
parentarm stable wrt bug #513378 (diff)
downloadhistorical-55dfd922dcef445642f8c69a18a4c92673d3bc54.tar.gz
historical-55dfd922dcef445642f8c69a18a4c92673d3bc54.tar.bz2
historical-55dfd922dcef445642f8c69a18a4c92673d3bc54.zip
Fix underlinking bugs #367589 (missing -luuid) and #514748 (missing -lm). Thanks to Diego Elio Pettenò, Christian Compagnon and Ted Tanberry. Fix missing include of string.h for strcmp() while at it.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'media-sound/lash/files')
-rw-r--r--media-sound/lash/files/lash-0.5.4-strcmp.patch12
-rw-r--r--media-sound/lash/files/lash-0.5.4-underlinking.patch23
2 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/lash/files/lash-0.5.4-strcmp.patch b/media-sound/lash/files/lash-0.5.4-strcmp.patch
new file mode 100644
index 000000000000..ea9f7ee2fda3
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-strcmp.patch
@@ -0,0 +1,12 @@
+clients/synth/lash.c:85:2: warning: implicit declaration of function ‘strcmp’ [-Wimplicit-function-declaration]
+
+--- clients/synth/lash.c
++++ clients/synth/lash.c
+@@ -22,6 +22,7 @@
+
+ #include "config.h"
+
++#include <string.h>
+ #include <unistd.h>
+
+ #include <lash/lash.h>
diff --git a/media-sound/lash/files/lash-0.5.4-underlinking.patch b/media-sound/lash/files/lash-0.5.4-underlinking.patch
new file mode 100644
index 000000000000..3e52807d267f
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-underlinking.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/367589
+http://bugs.gentoo.org/514748
+
+--- clients/control/Makefile.am
++++ clients/control/Makefile.am
+@@ -18,6 +18,7 @@
+
+ lash_control_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(LASH_LIBS) @READLINE_LIBS@
++ $(LASH_LIBS) @READLINE_LIBS@ \
++ $(UUID_LIBS)
+
+ endif
+--- clients/synth/Makefile.am
++++ clients/synth/Makefile.am
+@@ -20,4 +20,5 @@
+ $(JACK_LIBS) \
+ $(ALSA_LIBS) \
+ $(GTK2_LIBS) \
+- -lpthread
++ -lpthread \
++ -lm