summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-11-06 16:53:05 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-11-06 16:53:05 +0000
commit2089ab2d0459898a88d617bf870a9e3fcbbb0947 (patch)
treefe7a9f81513692b45c7d85bd20a7e60d3f259e70 /media-sound/kid3
parenttidy (diff)
downloadhistorical-2089ab2d0459898a88d617bf870a9e3fcbbb0947.tar.gz
historical-2089ab2d0459898a88d617bf870a9e3fcbbb0947.tar.bz2
historical-2089ab2d0459898a88d617bf870a9e3fcbbb0947.zip
Forcing KDE support on, as kid3 cannot be configured without having the KDE libraries installed. Also fixes bug #111692.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog6
-rw-r--r--media-sound/kid3/Manifest4
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild26
3 files changed, 18 insertions, 18 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index ed67fd2ee271..1d1fd5f4f767 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.16 2005/11/05 20:07:00 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.17 2005/11/06 16:53:05 greg_g Exp $
+
+ 06 Nov 2005; Gregorio Guidi <greg_g@gentoo.org> kid3-0.6.ebuild:
+ Forcing KDE support on, as kid3 cannot be configured without having the KDE
+ libraries installed. Also fixes bug #111692.
*kid3-0.6 (05 Nov 2005)
diff --git a/media-sound/kid3/Manifest b/media-sound/kid3/Manifest
index 67a6c2999853..e25240b6788a 100644
--- a/media-sound/kid3/Manifest
+++ b/media-sound/kid3/Manifest
@@ -1,6 +1,6 @@
MD5 b23600108f12c98a4fd574d3487ee598 metadata.xml 175
-MD5 1438a2492bfdde9e57e545219ae10286 kid3-0.6.ebuild 959
-MD5 f12732c060c0c470de4ab1c1d61cb823 ChangeLog 2113
+MD5 b62054eaf83f84b725f18f59dde0df8d kid3-0.6.ebuild 920
+MD5 6ca26f56ffac2eb93fce9bc9c0d14d7a ChangeLog 2306
MD5 3544b5449cbb9584580e2ce00130e9e5 kid3-0.5.ebuild 587
MD5 3031e9d49aa3af808d9a046e281ab344 files/digest-kid3-0.5 60
MD5 ca598674409d4fdd5c48e17ef0d436f7 files/digest-kid3-0.6 60
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
index 3c04ad520566..5eca255c8c79 100644
--- a/media-sound/kid3/kid3-0.6.ebuild
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.1 2005/11/05 20:07:00 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.2 2005/11/06 16:53:05 greg_g Exp $
-inherit kde-functions
+inherit kde
DESCRIPTION="A simple ID3 tag editor for QT/KDE."
HOMEPAGE="http://kid3.sourceforge.net/"
@@ -11,28 +11,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="flac kde musicbrainz vorbis"
+IUSE="flac musicbrainz vorbis"
-DEPEND="=x11-libs/qt-3*
- >=media-libs/id3lib-3.8.3
- kde? ( kde-base/kdelibs )
+DEPEND=">=media-libs/id3lib-3.8.3
vorbis? ( media-libs/libvorbis )
flac? ( media-libs/flac )
musicbrainz? ( media-libs/tunepimp )"
-set-kdedir 3
+need-kde 3
+
+# Support for the KDE libraries is optional,
+# but the configure step that detects them
+# cannot be avoided. So KDE support is forced on.
src_compile() {
- local myconf="$(use_with kde)
+ local myconf="--with-kde
$(use_with vorbis)
$(use_with flac)
$(use_with musicbrainz)"
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ kde_src_compile
}