summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-03-19 21:56:16 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-03-19 21:56:16 +0000
commitdecc37684d908b0be22bb9e9221f1020adc42a93 (patch)
tree1e70f8d6577091681641f3a0abc8261ce88f64ab /media-sound/alac_decoder/alac_decoder-0.1.1.ebuild
parentAdd ~alpha wrt bug #110574. Tested by Thomas Cort <tcort@cs.ubishops.ca> (diff)
downloadhistorical-decc37684d908b0be22bb9e9221f1020adc42a93.tar.gz
historical-decc37684d908b0be22bb9e9221f1020adc42a93.tar.bz2
historical-decc37684d908b0be22bb9e9221f1020adc42a93.zip
initial commit.
Package-Manager: portage-2.1_pre6-r3
Diffstat (limited to 'media-sound/alac_decoder/alac_decoder-0.1.1.ebuild')
-rw-r--r--media-sound/alac_decoder/alac_decoder-0.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/alac_decoder/alac_decoder-0.1.1.ebuild b/media-sound/alac_decoder/alac_decoder-0.1.1.ebuild
new file mode 100644
index 000000000000..149be2569917
--- /dev/null
+++ b/media-sound/alac_decoder/alac_decoder-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alac_decoder/alac_decoder-0.1.1.ebuild,v 1.1 2006/03/19 21:54:05 sbriesen Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Basic decoder for Apple Lossless Audio Codec files (ALAC)"
+HOMEPAGE="http://craz.net/programs/itunes/alac.html"
+SRC_URI="http://craz.net/programs/itunes/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin alac || die "install failed"
+ dodoc README
+}