summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2009-10-22 14:26:13 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2009-10-22 14:26:13 +0000
commit1010c0618f55e87c3b51248ef0f86dc77bface19 (patch)
tree82e06c182e04e537cfe9d473a8fb8c9918326276 /media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
parentinitial ebuild; theme for vdr-graphtft-0.3.1.x (diff)
downloadhistorical-1010c0618f55e87c3b51248ef0f86dc77bface19.tar.gz
historical-1010c0618f55e87c3b51248ef0f86dc77bface19.tar.bz2
historical-1010c0618f55e87c3b51248ef0f86dc77bface19.zip
version bump; svn revision 24; #276087
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild')
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
new file mode 100644
index 000000000000..ebe2240fdae8
--- /dev/null
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.1 2009/10/22 14:26:13 hd_brummy Exp $
+
+EAPI="2"
+
+inherit eutils vdr-plugin
+
+#MY_P="${PN}-${PV/_rc/-rc}"
+#S="${WORKDIR}/graphtft-${PV/_rc/-rc}"
+
+S="${WORKDIR}/graphtft-24"
+
+DESCRIPTION="VDR plugin: GraphTFT"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE_THEMES="+theme_deepblue theme_avp theme_deeppurple theme_poetter"
+IUSE="${IUSE_THEMES} directfb graphtft-fe imagemagick touchscreen"
+
+DEPEND=">=media-video/vdr-1.6.0_p2-r1[graphtft]
+ media-fonts/ttf-bitstream-vera
+ media-libs/imlib2[png,jpeg]
+ gnome-base/libgtop
+ >=media-video/ffmpeg-0.4.8_p20090201
+ imagemagick? ( media-gfx/imagemagick[png,jpeg] )
+ directfb? ( dev-libs/DirectFB )
+ graphtft-fe? ( x11-libs/qt-gui:4 )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="theme_deepblue? ( =x11-themes/vdrgraphtft-deepblue-0.3.1 )
+ theme_avp? ( =x11-themes/vdrgraphtft-avp-0.3.1 )
+ theme_deeppurple? ( =x11-themes/vdrgraphtft-deeppurple-0.3.2 )
+ theme_poetter? ( =x11-themes/vdrgraphtft-poetter-0.3.2 )"
+
+PATCHES=("${FILESDIR}/${P}_gentoo.diff"
+ "${FILESDIR}/${P}_makefile.diff"
+ "${FILESDIR}/${P}_gcc-4.4.x.diff"
+ "${FILESDIR}/${P}_ffmpeg-0.5.diff")
+
+extpatch_v_check() {
+
+ EXTPATCH_V="`cat /var/db/pkg/media-video/vdr-*/vdr-*.ebuild | grep EXT_V | head -n 1 | cut -c8-9`"
+
+ if [ "${EXTPATCH_V}" -lt "65" ]; then
+ echo
+ eerror "You need an update of vdr with a newer EXTENSIONSPATCH version!"
+ eerror "minimal version of Extensionspatch = 65!"
+ eerror "graphtft will not work fullfilled"
+ echo
+ einfo "use VDR"
+ einfo ">=media-video/vdr-1.6.0_p2-r2"
+ einfo "or"
+ einfo ">=media-video/vdr-1.7.0-r1 from vdr-devel Overlay"
+ echo
+ fi
+}
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ extpatch_v_check
+}
+
+src_prepare() {
+
+ sed -i Makefile -e "s: WITH_X_COMM = 1:#WITH_X_COMM = 1:"
+
+ ! use touchscreen && sed -i Makefile -e "s:WITH_TOUCH = 1:#WITH_TOUCH = 1:"
+
+ use graphtft-fe && sed -i Makefile \
+ -e "s:#WITH_X_COMM:WITH_X_COMM:"
+
+ vdr-plugin_src_prepare
+
+ sed -i "${S}"/imlibrenderer/fbrenderer/fbrenderer.c \
+ -i "${S}"/imlibrenderer/dvbrenderer/mpeg2encoder.c \
+ -e "s:libavutil/avcodec.h:libavcodec/avcodec.h:"
+}
+
+src_compile() {
+ vdr-plugin_src_compile
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe
+ sed -i build.sh -e "s:qmake-qt4:qmake:"
+ ./clean.sh
+ ./build.sh || die "build.sh failed"
+ fi
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ keepdir /usr/share/vdr/graphTFT/themes
+
+ dosym /usr/share/fonts/ttf-bitstream-vera /usr/share/vdr/graphTFT/fonts
+
+ dodoc "${S}"/documents/{README,HISTORY,HOWTO.Themes,INSTALL}
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe && dobin graphtft-fe
+ doinit graphtft-fe
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ if use graphtft-fe; then
+ echo
+ elog "Graphtft-fe user:"
+ elog "Edit /etc/conf.d/vdr.graphtft"
+ elog "/etc/init.d/graphtft-fe start"
+ echo
+ fi
+}