summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-06-27 21:46:02 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-06-27 21:46:02 +0000
commit89ae0fd21c3be0b2b2ab0d75cfd3f0b9fbbd1de5 (patch)
tree48180ab297813a03f9cb74ead96c20aa4188b72f /media-libs/mesa/files
parentStop fetching from git pointlessly after downloading the tarball. Add a patch... (diff)
downloadhistorical-89ae0fd21c3be0b2b2ab0d75cfd3f0b9fbbd1de5.tar.gz
historical-89ae0fd21c3be0b2b2ab0d75cfd3f0b9fbbd1de5.tar.bz2
historical-89ae0fd21c3be0b2b2ab0d75cfd3f0b9fbbd1de5.zip
Add missed file.
Package-Manager: portage-2.1.5.6
Diffstat (limited to 'media-libs/mesa/files')
-rwxr-xr-xmedia-libs/mesa/files/version.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/media-libs/mesa/files/version.mk b/media-libs/mesa/files/version.mk
new file mode 100755
index 000000000000..ab20d79daee4
--- /dev/null
+++ b/media-libs/mesa/files/version.mk
@@ -0,0 +1,17 @@
+#!/usr/bin/make -sf
+# Print the various Mesa version fields. This is mostly used to add the
+# version to configure.
+
+# This reflects that this script is usually called from the toplevel
+TOP = .
+
+include $(TOP)/configs/default
+
+version:
+ @echo $(MESA_VERSION)
+major:
+ @echo $(MESA_MAJOR)
+minor:
+ @echo $(MESA_MINOR)
+tiny:
+ @echo $(MESA_TINY)