summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-06-23 10:52:36 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-06-23 10:52:36 +0000
commit95445c1820049fb20456158ad189ad2644a4a4d8 (patch)
tree78e9f2da9f30aa7bc53f201eb7d3055cd50f16f2 /media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild
parentcleaning up obsolete versions (diff)
downloadhistorical-95445c1820049fb20456158ad189ad2644a4a4d8.tar.gz
historical-95445c1820049fb20456158ad189ad2644a4a4d8.tar.bz2
historical-95445c1820049fb20456158ad189ad2644a4a4d8.zip
fix stupid upstream configure, enable-encode disables encoder. Thanks bilboed for the patch, also been committed upstream in cvs
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild b/media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild
new file mode 100644
index 000000000000..52387c5e9400
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha4-r1.ebuild,v 1.1 2005/06/23 10:52:35 zaheerm Exp $
+inherit flag-o-matic
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="encode doc"
+
+RDEPEND=">=media-libs/libogg-1.1.0
+ >=media-libs/libvorbis-1.0.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.in
+ # fix stupid --enable flags
+ cd ${S}
+ epatch ${FILESDIR}/${P}-enable-flags.patch
+ # only here to fix stupid --enable flags
+ autoconf || die
+
+}
+
+src_compile() {
+
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
+
+ use doc ||
+ export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf \
+ $(use_enable encode) \
+ --enable-shared --disable-dependency-tracking || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ docdir=usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ dodoc README
+}