summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-29 18:09:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-29 18:09:29 +0000
commit7058f41036d149640d9c99ebe9fa543f8d47ace5 (patch)
tree7b99d296bea7b782f017b99190ac49d7733283ee /media-libs/libquicktime/libquicktime-0.9.4.ebuild
parentStable on hppa (diff)
downloadhistorical-7058f41036d149640d9c99ebe9fa543f8d47ace5.tar.gz
historical-7058f41036d149640d9c99ebe9fa543f8d47ace5.tar.bz2
historical-7058f41036d149640d9c99ebe9fa543f8d47ace5.zip
Fix check for xv useflag on xorg-x11 so that it's done only for 6.x series, fixes bug #135761. Fix quoting, use emake for installing, add patch to respect CFLAGS and not add extra CFLAGS that are unrequested.
Package-Manager: portage-2.1.1_pre1-r5
Diffstat (limited to 'media-libs/libquicktime/libquicktime-0.9.4.ebuild')
-rw-r--r--media-libs/libquicktime/libquicktime-0.9.4.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/libquicktime/libquicktime-0.9.4.ebuild b/media-libs/libquicktime/libquicktime-0.9.4.ebuild
index e2eb558f1ef8..498446987048 100644
--- a/media-libs/libquicktime/libquicktime-0.9.4.ebuild
+++ b/media-libs/libquicktime/libquicktime-0.9.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libquicktime/libquicktime-0.9.4.ebuild,v 1.10 2005/12/26 12:34:58 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquicktime/libquicktime-0.9.4.ebuild,v 1.11 2006/06/29 18:09:29 flameeyes Exp $
inherit libtool eutils
@@ -28,7 +28,7 @@ DEPEND=">=sys-apps/sed-4.0.5
PROVIDE="virtual/quicktime"
pkg_setup() {
- if has_version x11-base/xorg-x11 && ! built_with_use x11-base/xorg-x11 opengl; then
+ if has_version '=x11-base/xorg-x11-6*' && ! built_with_use x11-base/xorg-x11 xv; then
die "You need xv support to compile ${PN}."
fi
}
@@ -36,10 +36,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-cflags.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-cflags.patch"
- sed -i "s:\(have_libavcodec=\)true:\1false:g" configure.ac
+ sed -i -e "s:\(have_libavcodec=\)true:\1false:g" configure.ac
ebegin "Regenerating configure script..."
autoconf || die
@@ -50,10 +50,10 @@ src_unpack() {
src_compile() {
econf --enable-shared \
- --enable-static \
- $(use_enable mmx) \
- $(use_enable gtk) \
- $(use_enable ieee1394 firewire)
+ --enable-static \
+ $(use_enable mmx) \
+ $(use_enable gtk) \
+ $(use_enable ieee1394 firewire)
emake -j1 || die "make failed"
}