summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-28 18:46:52 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-28 18:46:52 +0000
commitc191c4630a65fc31a4e74a6b61a6c3781a2b08e6 (patch)
tree0e82c1f9a99815d91318ab2f10d8cf92693a9eda /media-libs/libextractor/libextractor-0.2.2.ebuild
parentMoving to media-libs/libextractor (diff)
downloadhistorical-c191c4630a65fc31a4e74a6b61a6c3781a2b08e6.tar.gz
historical-c191c4630a65fc31a4e74a6b61a6c3781a2b08e6.tar.bz2
historical-c191c4630a65fc31a4e74a6b61a6c3781a2b08e6.zip
move to media-libs
Diffstat (limited to 'media-libs/libextractor/libextractor-0.2.2.ebuild')
-rw-r--r--media-libs/libextractor/libextractor-0.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libextractor/libextractor-0.2.2.ebuild b/media-libs/libextractor/libextractor-0.2.2.ebuild
new file mode 100644
index 000000000000..7b3146ba2786
--- /dev/null
+++ b/media-libs/libextractor/libextractor-0.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libextractor/libextractor-0.2.2.ebuild,v 1.1 2004/04/28 18:46:52 squinky86 Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="A simple library for keyword extraction"
+HOMEPAGE="http://www.ovmj.org/~samanta/libextractor"
+SRC_URI="http://www.ovmj.org/~samanta/libextractor/download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="oggvorbis static"
+
+# does not work with rpm-4.2
+DEPEND=">=sys-devel/libtool-1.4.1
+ <app-arch/rpm-4.2
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+src_unpack() {
+ unpack ${A}
+ # patch their half baked attempt at supporting ogg vorbis
+ epatch ${FILESDIR}/${P}-vorbisfile.patch
+}
+
+src_compile() {
+ elibtoolize
+
+ export CPPFLAGS="-I/usr/include/rpm"
+ econf `use_enable static` || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}