summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-22 12:33:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-22 12:33:36 +0000
commit5251eeeca0a81e6ec5dd20b753e78613cdc2671e (patch)
tree6a64d14f9fddb8bd6763896465d3af1a340a3207 /media-libs/id3lib/id3lib-3.8.3-r8.ebuild
parentStable for HPPA (bug #408983). (diff)
downloadhistorical-5251eeeca0a81e6ec5dd20b753e78613cdc2671e.tar.gz
historical-5251eeeca0a81e6ec5dd20b753e78613cdc2671e.tar.bz2
historical-5251eeeca0a81e6ec5dd20b753e78613cdc2671e.zip
USE="static-libs" and remove libid3.la when it's disabled.
Package-Manager: portage-2.2.0_alpha92/cvs/Linux x86_64
Diffstat (limited to 'media-libs/id3lib/id3lib-3.8.3-r8.ebuild')
-rw-r--r--media-libs/id3lib/id3lib-3.8.3-r8.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/media-libs/id3lib/id3lib-3.8.3-r8.ebuild b/media-libs/id3lib/id3lib-3.8.3-r8.ebuild
index fa853bb45e41..a5f3c452ebce 100644
--- a/media-libs/id3lib/id3lib-3.8.3-r8.ebuild
+++ b/media-libs/id3lib/id3lib-3.8.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.3-r8.ebuild,v 1.8 2012/02/25 15:06:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.3-r8.ebuild,v 1.9 2012/03/22 12:33:36 ssuominen Exp $
EAPI=4
inherit autotools eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
RESTRICT="test"
+DOCS="AUTHORS ChangeLog HISTORY README THANKS TODO"
+
S=${WORKDIR}/${P/_}
src_prepare() {
@@ -30,24 +32,27 @@ src_prepare() {
"${FILESDIR}"/${P}-doxyinput.patch \
"${FILESDIR}"/${P}-unicode16.patch \
"${FILESDIR}"/${P}-gcc-4.3.patch \
- "${FILESDIR}"/${P}-missing_nullpointer_check.patch
-
- # Security fix for bug 189610.
- epatch "${FILESDIR}"/${P}-security.patch
+ "${FILESDIR}"/${P}-missing_nullpointer_check.patch \
+ "${FILESDIR}"/${P}-security.patch
AT_M4DIR="${S}/m4" eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_compile() {
- emake
+ default
if use doc; then
- cd doc
+ pushd doc >/dev/null
doxygen Doxyfile || die
+ popd >/dev/null
fi
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog HISTORY README THANKS TODO
+ default
+ use static-libs || rm -f "${ED}"/usr/lib*/lib*.la
use doc && dohtml -r doc
}